This is the thread for Advanced LifeMap problems

Supporters Only

Lately there have been some issues where the advanced LifeMap that Supporters have access to disappears or strangely breaks. :scream:
I’ve made some decently large changes that I want to keep an eye on. :male_detective:

Let me know if your advanced LifeMap disappears, or you notice performance issues (I’m guessing things like the purple lines taking longer to draw on the map, maybe), or if it takes a lot longer to regenerate (although, make sure to double check the status page).

Please Provide This Information

  • Your profile link
  • The date of your newest activity in CityStrides
  • Roughly the last date you looked at your LifeMap
  • How soon after your newest activity in CityStrides are you now viewing your LifeMap?
  • For you newest activity - did you have more than one activity that day?

What I’m trying to figure out is whether or not creating the new activity is the thing that breaks the LifeMap. Each time an activity is saved, the LifeMap is regenerated - so I’m expecting that this regeneration sometimes fails.

3 Likes

This morning, my map is missing but also my profile is all scrambled. There are images and symbols that are really large on the page. It’s like everything is just stacking on top of one another. This is my page address: https://citystrides.com/users/5667

Lifemap disappeared for this morning (9am MST). The first time I went to my home page didn’t even come up (just a big “CityStrides” logo). 10 min later I could access my account, but the map didn’t show any running tracks.

https://citystrides.com/users/7875/map I just went now and its empty.

Note: fine on mobile, missing on desktop.

Note2: shift refresh fixed desktop.

The last time I saw my map was late last night, 4/28. My last activity date would have been 4/28 but that never synced. CORRECTION: That last 4/28 activity did sync. Sorry.

Same here. Everything looked fine last night. My activity did sync though.

As of right now, I’ve verified that both @lucialzag & @westbyc files are not corrupt. So both of your advanced LifeMaps should be functioning properly right now if that’s the cause here.

Sorry for the hassle, but can you try viewing again?
If it still doesn’t work, can you try opening a private/incognito window … logging into CityStrides (very important step) … and checking in there?

Let me know about both attempts. :+1:

Incognito works perfect… normal google chrome nope.

Just to be sure (I apologize for even asking, but it’s very important for my debugging) … you were logged in within that incognito window, right?
The reason I ask is because there are two versions of the advanced LifeMap for each user - a private version (shown to yourself while you’re logged in) and a public version (shown to anyone else). So we’d be testing two completely different things if you weren’t logged in.

This is sounding like it’s connected to the browser cache somehow. The mapping software I use does it’s own cache thing with this particular data I’m using for the advanced LifeMap.

While you’re logged into CityStrides in normal Chrome and looking at your LifeMap, can you try holding down the shift key while refreshing the page to see if that causes some of the data to reappear?

Thank you so much for helping out with all this tedious debugging! I’m sorry you have to do any of it.

1 Like

Yes, I was in incognito. And pressing shift and refresh brought the map back! Thanks!

Did it bring it back for all zooming/panning?

I think so… I haven’t tried everything, but I think it looks good. I have been moving it, zooming certain areas of my town. It looks good…

I just cleared my browsing data in chrome and I’m back in business. Everything seems to be working right.

I’m having the same issues here. My profile picture is also gone. When I go to the url in incognito, it works fine.

Did you try a shift+f5 reload?

Yeah @m.george.brown89 Give that a try

Also if that does work - please respond back with whether a single shift refresh fixes the LifeMap for all zoom levels or if you need to keep shift refreshing for many zoom levels

My map doesn’t show my runs either: https://citystrides.com/users/18387/map

I’ve cleared caches, hard refreshed, and checked on mobile already but no dice. I’m a new user though (less than a day), maybe it needs time to sync?

Edit: working now

Hi,


My last activity was May 2 https://citystrides.com/activities/9794789 - however it was during this run that i was using chrome on my android phone (as i often do ) to see what roads i need to run, 99% sure logged in. but lifemap wasn’t loading (map tiles load but never shows purple line). my run previous to this was 1st May.

So today I use chrome on my macbook, and the same thing happens.
When i click on my city from my profile, it shows the purple lines, but as soon as i zoom in the lines go away (presumably cached ok in the zoomed out view of the city).

thanks
Chris