Recent activities not reflected in LifeMap

I’ve been seeing an issue as well. Normally a lag (time varies from 30min-90min) for the activity to show. Then once it shows the Streets Completed/Progressed isn’t correct–they all show “progressed”. At some point later the LifeMap updates and the streets Completed/Progressed is cleaned up. I’ve also noticed that I only show one activity import where I used to show two (Strava and MapMyRun).

The advanced LifeMap should be a decently quick update. This thing of it taking days is new, and seems to be a browser cache issue as opposed to a data generation issue. I have an idea of how to handle this that I’ll try to get released tonight or tomorrow night.

I’m pretty sure it’s not a browser cache issue. I’ve tried three different browsers on two devices, each after having cleared all cached content. Sync was pretty quick today though.

I have to echo this, I don’t think its a browser cache issue (unless its this + another issue). When its taking many hours after the activity has processed I have tried different browsers and devices as well.

The first issue is the delay: CityStrides
So that’s currently ~2hrs after an activity is created (processing isn’t playing a role here)

The second issue is the browser cache, where the LifeMap has been generated but the browser is not displaying those changes.

I can fix the first issue by throwing more servers at the problem. I just need to figure out the best way to efficiently do that.
I have some ideas on how to avoid the second issue. I haven’t implemented those, yet, because I’m focused on the sync/api limit issue.

Personally, I don’t mind a few hours delay in syncing or processing. Is the 30.000 API call limit a per server (node) cap?

Regarding the second issue, how can you be sure it’s browser cache related? I’ve just logged in from a freshly installed virtual machine and the traces from the last few days are still missing (nodes are ticked off though).

I’d be happy to run some tests if that would help.

Oh, no, not the Strava delay. The LifeMap generation delay (right side of page on desktop, very bottom on mobile).

I’m saying that it’s either a browser cache issue or it’s the generation delay. Those are the only two factors at play. (Oh it’s also possible that the generation is failing, but that would be new and surprising). I’m expecting that you’re experiencing the generation delay, but I’ve helped people who were experiencing the browser cache issue - so I know that this exists.

My best guess is that there’s something wrong with map creation. Is the node administration part of the lifemap generation process or something entirely separate, just an overlay on the lifemap from a different source?

Nice - I realized before replying that this could be useful in #wiki so I updated About The LifeMap

Nodes play absolutely no role whatsoever in the LifeMap display. They’re only referenced via NodeHunter, which is a decently simple query of “give me the unfinished Nodes for unfinished streets in the current browser view.”

Ooh, also, I took a step back to think of any possible way that there could be something wrong with map creation (the actual building/serving of the advanced LifeMap is one of the most reliable pieces of the site so far). There was a bug with the plugin I use to generate encoded polylines a couple days ago, and it looks like that did affect 11 of your activities - so that’s what was causing the LifeMap to fail to build. I’ve queued up your account again, so that should work properly this time - looks like there’s a ~40min delay in there.

Thank you for clarifying how this works. I really appreciate the effort that goes into bringing all these elements together, like conducting a small orchestra of misbehaving musicians :slightly_smiling_face:

1 Like

That is quite accurate. :laughing:

1 Like

I just posted this elsewhere, but will share again here in case it helps others:

So this is weird. I use mostly Edge as my browser. Although much time has passed, LifeMap was not up to date. Tried clearing cache (cookies and saved website data & cached data and files) and got message “some data could not be cleared. please try again.” I did, many times. No luck. Maybe the data is still “open” although I have no CS tabs open.

So went to Chrome, cleared data with no problem, and LifeMap on Chrome is correct.

Not sure why the problem with Edge, but I’ll be sticking with Chrome for CityStrides.

Hi! My activity synced today with no problems, but not my activity yesterday? Weird! Anything that can be done?

Post to the other thread that says “Reply Here If You Have Missing Activities” or just delete your activity from Strava and re-import it which is what I did for my missing run from yesterday.

I am a bit confused with the threads… Okay. My activity synced today, but not yesterday…

Sorry @lucialzag I moved this back over here because I need that other thread to be clean and without any discussion. I cannot keep up with the workload otherwise.

There’s a lot of sync delay because of a lot of new signups. I’ll need a link to your profile page (available in the top right menu) to help you out from here.

Fixed! Thanks!

Lifemap still does not show the streets, but my profile does. I guess tomorrow. Sorry for bugging.

Nothing has updated for 3 days now. I’ve tried signing out and back in, hitting the sync button (which is now gone as of today), and wondering what else I can do?
Update, my activity from today has posted, but still missing one from the 29th of March.

Please read and follow the directions in this first post here: Reply Here If You Have Missing Activities
I’m working through the backlog as fast as I can :sweat: