Strava GPS is accurate, City Strides is not

Hello! @JamesChevalier thank you for all you do.

I noticed that my past 3 runs (2 yesterday, 1 today) are accurate on my Strava map, but they are off on the City Strides map. I deleted my run for today, and put myself in the queue to re-sync. But, now I’m wondering if I should delete all of my inaccurate runs, in the hopes that they will all eventually accurately sync up. Thoughts? Thank you, thank you!


Can you elaborate more on this inaccuracy?

Can you share links to activities in Strava and here? (If they’re private, I’ll respect that as a “no” - there’s no reason to decrease your privacy)

I’m receiving coordinates from Strava and should be carrying those along exactly as they are. I did just update the underlying plugin that helps me generate some map visuals, so I’m wondering if that’s problematic.

In any event, unless the Strava data is wrong (doesn’t seem to be) or if the sync somehow failed partway through (a major break in how any of this works) then I should be able to fix this problem without anything being deleted.

I’m having the same issue with todays run.

Same issue for me. Garmin → Strava looks good, but when it gets to CityStrides, the GPS data is way off. Going to try to add two (phone) screen captures.

This should be a link to the activity showing the same distance, 2.64 miles.

And this should be the activity in Strava, I will check next to make sure not private. Shouldn’t be, but not sure.

I updated the plugin I use to generate these lines and it looks like their new version is broken. I have a few options to fix this, none of them requires any changes/deletions/resyncs etc … I’ll be able to fix it tomorrow, no problem.


@JamesChevalier Good to hear. I was quite perplexed. Thank you!

PS. Added link to Strava activity above.

hey @JamesChevalier. New user here and really loving the app.

I had an issue today and was wondering if it might be connected to the same above? If so, I will just await the changes today but if not could you help? Screenshot of City Strides incorrect map attached

Same issue here. Data for yesterday’s run ported in from an alternate universe :crazy_face:

1 Like

Update on this:

I’m about to roll back to the previous version of the plugin that generates these maps. Then I’ll regenerate the maps for all the activities since yesterday.

This is a purely visual issue. There is no issue with the underlying coordinate data, so progressed/completed streets will all work out correctly.
Nobody has to do anything - no resync required, no delete required - I’ll be able to fix it all up.

In the meantime, I created an issue with the plugin creator and I’ll see if I can work with them on a fix. :+1:


I’m OK waiting for the re-gen, but curious about the following:

If there is no problem with the data, shouldn’t I see some numbers for completed and progressed (on 3/26/2020)? I did this run specifically to pick up new streets (all were new). I did another run yesterday (no sync yet) to get a few I missed (Shasta, part of Tahoe, and Forest Lakes Ct.). Then a ran new streets east of Rufe Snow.

Thank you for the challenge of doing new routes!


See Activity Processing Delay in CityStrides

1 Like

“Post-sync processing.” Got it. :+1:

@JamesChevalier looks like the individual activity maps have corrected but lifemap still not updated. I’m assuming this one just takes a bit longer?

Yeahp. :frowning_face:
That’s “LifeMap Generation Delay” in CityStrides


Looking good! Same data as my first pic above. Kudos!

Now for the Activity Processing Delay to catch up, currently 19 hours.

Hello, I am still waiting for this morning run to show on the map ( it’s been 12h) but my last run that was fixed has gone berserk again

So this is weird. I use mostly Edge as my browser. Although much time has passed, LifeMap was not up to date. Tried clearing cache (cookies and saved website data & cached data and files) and got message “some data could not be cleared. please try again.” I did, many times. No luck. Maybe the data is still “open” although I have no CS tabs open.

So went to Chrome, cleared data with no problem, and LifeMap on Chrome is correct.

Not sure why the problem with Edge, but I’ll be sticking with Chrome for CityStrides.

I can’t tell from the screenshot what is bad/good.
Can you share a link to the activity itself?