LifeMap is blank


#1

My life map is not showing ANY streets or past runs. When I look at my profile individual runs are showing up, but the Life Map is devoid of any markings. This just happened today. I’ve logged out and back in to no avail. Please help, thanks!


Can't see my heatmap (empty map)
My lifetime map has disappeared
My lifetime map has disappeared
#2

Your LifeMap is incredibly not blank for me. :astonished:

That’s quite a bit of data, I wonder if the browser is having trouble displaying it all…
Are there any errors reported in your browser’s console? You can check this by visiting your LifeMap page, and then…

For Firefox:

  • Open the Tools menu
  • Open the Web Developer submenu
  • Select Web Console
  • Any errors in there?

For Chrome:

  • Open the View menu
  • Open the Developer submenu
  • Select JavaScript Console
  • Any errors in there?

For Safari:

  • Open the Develop menu
  • Select Show JavaScript Console
  • Any errors in there?

For IE:

  • :man_shrugging: maybe a similar process
  • Any errors in there?

#3

James - thanks for your suggestions. I followed your instructions for Chrome, this error is listed:

mapbox-gl.js:521 Error: RangeError: Maximum call stack size exceeded
at Actor.receive (mapbox-gl.js:501)
Evented.fire @ mapbox-gl.js:521
map:1 The SSL certificate used to load resources from https://doug1izaerwt3.cloudfront.net will be distrusted in M70. Once distrusted, users will be prevented from loading these resources. See https://g.co/chrome/symantecpkicerts for more information.
map:1 The SSL certificate used to load resources from https://bam.nr-data.net will be distrusted in M70. Once distrusted, users will be prevented from loading these resources. See https://g.co/chrome/symantecpkicerts for more information.

Any idea how this can be addressed/fixed?

I love your site, by the way!


#4

Hi James,

I get the same thing Bill Hutchinson is getting when I use Safari browser, but my map comes up just fine on Firefox.

Any idea how we can clear the “maximum call stack size” problem?

Thanks!


#5

The weird thing is that I can view other peoples stuff, just not mine…


#6

Thanks!

I was also able to recreate the issue within Chrome & Safari. Firefox works fine for me :man_shrugging:
I’ve submitted this issue with Mapbox & I’ll keep everyone up to date here with how things play out:

Small Update: I’ve found that it’s something within Mapbox’s code… An older version of their plugin works properly, while later versions do not. I’ve left the old version in place - so you should all be able to see your LifeMap again. I’ll continue working with Mapbox to see if I can help figure this out for their future versions.


My lifetime map has disappeared
#7

Thanks for looking into this. I’ve downloaded Firefox and can now again stare (obsessively!) at the LifeMap! Keep me posted on how things go w/ resolving Chrome. FYI - I didn’t mention previously but I also had tried Explorer and had the same error there.


#8

Thanks James!

You are the best!!!

RT


#9

Just to mention that I also have this problem.


#10

Quick update…

I found that the problem is bad data. Here’s an example activity (for however long the link remains active):

Bill’s quite the geometric artist, working off the coast of Ghana. :wink:

Now that I know the cause of the issue, I can start looking into how it can be fixed…


#11

Nice… I’ve been (not) seeing the same thing


#12

Just curious if a solution has been found as I two am having the issue. Wasn’t sure if it was caused by indoor/treadmill running?


#13

I don’t know if this is useful to add…

… In other news… it’s actually a nice challenge for me to target streets without referring to the map. My wife is also happy that i’m not spending hours staring at a map… only minutes seeing if it’s restored…:face_with_raised_eyebrow:


#14

samteigen - In case you need to sneak a peek at your LifeMap you should be able to access it via Firefox browser.


#15

Thanks for the reminder. I had to update firefox to the current version for it to work.


Can't see my heatmap (empty map)
#16

When I log out, I’m able to see my lifemap.
When I’m logged in, it is not possible. (log in via Strava)


#17

Hello!

When I open my LifeMap I don’t see any of my runs. I can see other people’s LifeMaps and theirs looks fine.

My map is just an empty map even though I can see my activities have been synced and it shows 21% complete.

I’ve tried using different browsers and computers with no success.

Any idea what could’ve caused that?

Thank you!
Lucas


#18

I have the same issue, it’s all disappeared…


#19

Have a look here, there was another post on it recently. @JamesChevalier gave tips on looking for errors in various web browsers.


#20

i can see my activities from strava but they don’t show up in my lifetime map??? any ideas?