My location issue

:link: My profile link : CityStrider Paul - CityStrides

Here’s my issue. Since I updated to iOS 16.1 on my iPhone, I can no longer see my current location on my map. I’ve tried this in both the Chrome and Safari browsers for iPhone. When I click logout, log back in fresh, and then go to Lifemap and click the My Location button on the right-hand side of the screen, on Chrome it prompts me to allow the app to use my location, then the icon turns blue and just spins. It never resolves to my location. On Safari, clicking the button prompts for location access, then the button grays out and no location is displayed.

I’ve looked through the Settings for the apps, etc. I can’t find anyway to resolve the issue. I double checked on my iPad using Chrome and Safari browsers, iOS 15.6, and location works just fine. So I’m thinking this has to be related to the new OS version.

I really rely on this view when walking to understand where I’ve been and where I am in relationship to past activities. Help.

:thinking: @nurseangel72 also mentioned this in the chat:

Originally sent in Water Station

Is there an issue with location and the new iOS? Mine is just spinning all day


No issue here... You my try checking location permissions (turning them off/on?) or rebooting :person_shrugging:


I’ve tried everything. It just turns blue and spins… all day

I’m also on the latest iOS, and I cannot reproduce the issue. Another guess I have is trying to remove the site’s data & trying again:

  • Settings
  • Safari
  • Advanced (all the way at the bottom)
  • Website Data
  • Search “citystrides”
  • Swipe the entry for and tap Delete

Let me know if that helps…

Hit the settings hard again. I got it to work in Safari. Chrome browser on iOS 16.1 still a no go.

I have the exact same problem. Both chrome and safari.

I tried the suggestions for safari and deleted all from saved data, but it didn’t help.


While in this state of the location feature just spinning… Do other interactive bits of the website work as expected? Short list of things, some of which may not be available depending on which page you’re on:

  • Flipping back and forth between Satellite view
  • Show/Hide streets on the map
  • Show/Hide city borders on the map
  • Route Builder
  • Node Hunter

All of those work as expected.

It’s still not working on chrome. Works on safari but I have to login constantly on safari so quite annoying. The other features are working for me

With Safari everything works for me. I don’t normally use Chrome, but now I tested and I got the same problem as reported above. Checked Settings and it was OK.
Then had an idea, in Settings - Chrome - Location I chose ”Ask next time”. Killed my Chrome instance and opened again. This time when I press the location button I get the question ”Do you allow Chrome to use your location?” Answer ”yes when app is used” and now it works! And it seems to be persistent. But remember you have to kill the Chrome instance on the phone after changing settings, otherwise it won’t read your change from Settings

1 Like

Hans - Thanks. That did the trick. Everything is working fine now. I suspected some version of turn it off and turn it back on would reset things. You skillfully found the right order of operations. Woot!

Thanks for sharing those details!

I added Resolving common issues with location access for LifeMap Live to the #wiki
I’d like to keep that wiki post updated with potential fixes, as we all learn more :raised_hands:

I’m wondering if that ‘completely exit’ step is particularly important - even for the folks having trouble in Safari. I’ve update that wiki post to include that in the process, but I’ll need people to try it out to confirm/deny its helpfulness.

My 2 cents. This had been happening with my iPhone with Chrome browser for weeks. In my case I just go through the steps that @hans1 listed to get the prompt. In my case I “do” have to kill Chrome first but it also doesn’t fail every day…it’s sporadic.

This worked for me as well. Thanks!

Since the most recent iOS update my location finder hasn’t been working on the chrome browser. I’ve tried restarting my phone to no avail. It seems to work fine on Safari, but the location finder just spins endlessly for me on Chrome after I accept the location permissions. Any ideas what could cause this?

Have you checked this? Resolving common issues with location access for LifeMap Live

1 Like

After the latest upgrade of iOS, this issue is back, and this time it does not help to close Chrome completely, change settings to ask for location and reopen chrome again. This was my goto solution.

Kinda sucks, but I assume it’s an OS problem, not a CS problem? Not sure what to do, so I was wondering if anyone else has this issue again and managed to solve it, when the mentioned solution doesn’t work anymore.

Yes, something must have changed in IOS. My old fix doesn’t seem to work anymore in Chrome. Safari is still OK it seems

1 Like

I switched to Safari as well after the Chrome fix stopped working.

I don’t know why, but unfortunately, location doesn’t work in Safari for me and never has. I have tried both with settings “ask next time” and “allow”. If it asks, I allow. But then I get a greyd out icon with a red line over.

I would check two things…

Settings → Privacy & Security → Location Services
Ensure those are enabled at the top

Scroll down that list to find Safari Websites
Ensure that While Using the App is selected and ensure that Precise Location is enabled


THANK YOU!! It was in the privacy and security settings, Safari location was set to Never! Phew, what a relief to be able to see my location again.