Life map keeps crashing


Every time I try and go onto the life map it loads and then after a couple of seconds reloads it a couple of times before crashing :frowning:

I’ve tried all the obvious fixes - log out, log in, change browser, restart phone etc but I’m now at my wits end.

Is the message I get.

Is my profile. Any suggestions appreciated!

Many thanks

Edited to add - I’ve tried it on a different phone and a laptop and I’ve still got the same problem so seems it’s an issue with my account/city strides rather than the device/browser.

1 Like

:thinking: It’s working for me, but we do have public/private versions of our LifeMap … I queued up a rebuild, to see if that helps (give it ~30mins).
I am testing a different data format, so I’m wondering if that’s playing a role … I would have expected at least one of your devices to work properly, though.

  • Which iPhone do you have?
  • How much RAM does your laptop have?
  • Does your LifeMap work in a private browser window?

I’m going to jump in this thread to say that I’ve been having the same problem starting last night. The problem seems to only be on mobile for me; I use an iPhone 7 Plus, iOS 15.1. I tried both the Safari and Chrome browser (although I understand they both use the same rendering engine under the hood). In Safari, I see the same error message that @templeria posted originally.

Same with me in UK today …. Times out on iPhone and iPad and really slow on laptop … was working a dream last week on all 3

Hiya, thanks for looking at it for me. So I’ve two iPhones - an 11 and an old 6s for work. Tried on Safari and Google and the same problem on all, especially when you try and zoom in. I just tried again in a private window and same thing happened.

My laptop seems a bit more stable but very slow now and has crashed out a handful of times as well. Not sure off the top of my head how much RAM it has as I’m out atm but it’s less than a year old, and I work a lot with graphics and video so I know when I bought it I made sure it had a goodly amount and a decent graphics card (sorry that’s not terribly technical I know!).

Same. Currently citystrides website is unusuable on my iphone 12. It is super slow to load on my laptop (macbook pro) using firefox. Like comically slow…

Everything was working great but then i noticed yesterday late morning (pacific coast time here), the website started to bog down and I was getting the problem repeatedly occurred notice on my phone.

Quick note - this is definitely an issue in my code so don’t try to “Do Stuff” to try to fix it. It’s on me. Don’t revoke access, don’t delete stuff, don’t do anything :laughing:
Very sorry, but I am looking into it & I will fix it


I have a similar, perhaps related issue. When I try to zoom in on a city map it either reloads the page or gives me an error saying Can’t open this page. I’m using Chrome on an iPhone 13 Pro. Worked fine on a different city on Thursday.

Thanks, me too. Jim in Sheffield

It feels like a memory leak

Same here. Zooming in triggers issues.

Same here! Good luck with the fixing :grimacing:

On an iPad (fully updated iOs), the Lifemap crashes (sometimes it shows a map but usually just crashes). On a PC, it shows the populated map after hanging, and then is very slow if I zoom in, sometimes not populating at all.

Wondering if the city page works for you - if you go to your profile page, and then visit a city page from there … does it perform the same way, crashing/not showing the map … or does it work as expected?

// @asstrid @makarovfan @mlehotay @4e2c71bc69f7d92608f3 @lizzyjm @AWDK @templeria @kerpaujames

@irowe.bbn I’m surprised about your experience just happening the other night. The non-supporter LfieMap has been changed over to this format for a while. :thinking: And before that it used a similar data format that I had seen produce some odd errors/crashes (searching the forum for ‘too much data’ might dig up some past conversations - honestly not super useful, but if you’re interested).

Hopefully I’m not giving you bad troubleshooting info, but I’m pretty sure I used my LifeMap without trouble before my long run on 2022-01-29. The next time I remember checking is on 2022-02-11, and that’s when I ran into the problems mentioned earlier.

on my iphone 12 (which has been unusable for citystrides of late), it works to look at individual activities from my profile page. i can see the map associated with each day’s run.

If I go to my profile page>city - it does build the life map of the city. However the first time I did this, I got this error: A problem repeatedly occurred on “”. Once I refreshed, now it seems to be working.

In general it works for me, but veeeerrrryyyy slowly. Takes about 2 minutes (?) to draw lifemap, and then zooming or panning causes additional problems. I just turned on the browser console and loaded a city page. Attaching screenshot…

It is working on and off for me, but the activities that I did over the last two days aren’t showing up at all on there. That’s not a problem at all until next weekend, and not an unsurmountable problem for quite a while.

Just checked on my phone and same problem going in from a city page - map loads then as soon as I try and zoom in at all or move the map, it crashes.

City map from profile loads but also crashes but also keeps reloading before it crashes. Lifemap just crashes directly without loading.