Life map keeps crashing

I primarily use the city page and that was showing the error all day yesterday and today. The city pages are fine at first, but if you change the zoom in any way, it either redraws back to the default zoom, or it errors out.

Looking at individual data seems to work fine.

Today I did 3 dead-end allies where the node is still red at the end of the alley. The uploaded route only goes about half-way even though I walked to the very end. :confused:

Thanks, everyone, for confirming that city pages also have the issue. The extra detail of hearing that the page might load successfully, but that zooming/panning the map can cause crahes/other issues is helpful.

Sharing your device info will also be helpful (e.g. iPhone 12, or in the case of computers how much RAM & which browser).

:thinking: None of the code these errors reference is mine. I have no idea what that code is - maybe a browser extension?

Thanks, everyone, for your patience. This is a terrible issue to experience. I’m working as hard as I can to resolve it.


That’s what I was doing - going to a city page from my profile. Just tried again on two different cities and also on my life map and it’s still doing the same unfortunately - just can’t zoom in enough.

Quick update for everyone … It’s looking like this is caused by bad GPS data.
@templeria has a good example of one problematic activity here - Claire Avery's activity on August 29, 2021 - CityStrides - particularly around miles 4-7.

If you search around the forum for “too much data”, you’ll find many other instances of the maps failing in some way or another. I’ve always figured it was the device running out of memory because too much data was being displayed … I’m thinking now that it’s actually this issue & it’s more common with people who have lots of activities because that makes it more likely for there to be bad GPS.

I’m pretty sure that one of the reasons that the Advanced LifeMap (prior to this ongoing issue) fixed this is that the GPS data is simplified a little bit during the process.

I am currently working on restoring the previous setup.


How is it going?
Tried to use the map today (Iphone 11/Safari) but it is worse than on Sunday. I was not able to look at the map without crashing - I tried Lifemap, City, toggling.

I can see that on my phone - in a glimpse - that the map there is not updated - while the map on my computer is.

If it helps, it’s fine on my laptop, just my phone that has the issue. Can’t really go for a run or walk with my laptop though :joy:

Using the location button breaks it as well, as it zooms in further than it can handle.

1 Like

I am receiving the same error message… my life map keeps crashing especially when I try to zoom in.

This fix is out now. The advanced LifeMap should now be functional for everyone. You’ll have to refresh the page once, but only if you already have it open.


Great - it is working again.
Thank you :smile:

Not sure what i am doing wrong but my lifemap still has the same problem.
Iphone 11 pro. Latest app version and iOs

Amazing - seems to be behaving again for me. Thank you! :slight_smile:

Works great now. Thank you for all the work you put into this!

Thanks James

That’s because the issue (some more details up this thread a bit Life map keeps crashing - #24 by JamesChevalier about weird GPS) still persists for non-subscribers. Fixing the issue costs me money, and I haven’t figured out a way to reduce those costs enough in order to make everyone’s LifeMap use this data format. :slightly_frowning_face:

Clear, thanks