Invalid Credentials for login w/ Strava

I’m running into some issues logging in through my Strava account. It gives me a error saying invalid credentials. Not sure if this is a Strava issue or if its caused by the backlog from all the new users? Any suggestions or fixing it? I’ve tried logging out of Strava and then signing everything back in but no luck. It was working great previous to this weekend.
Thanks.

I think this is due to the large influx of new members. The site is syncing all these new activities & I think I’m hitting Strava’s limit.

We’re down to about 3m jobs queued up, which is down from the 15m that were queued on Saturday. So, it’s moving along nicely & should wrap up early in the week.

Until it gets back to normal, you might have a better chance of trying to log in right after the quarter hour. That’s when Strava resets the limit, so you might have a window between :00 and :01 or :15 and :16 or :30 and :31 or :45 and :46 where you can log in. :grimacing:

Really sorry for the trouble… My budget limits me quite a bit as far as handing load is concerned - I can’t really put in more money each month to increase servers.

Have patience, though! People really like it when it’s all working properly. :smile:

1 Like

No worries James. I love the site. I’ll give the time window a shot, if not I’ll just wait for a day or two. I think its great seeing the site becoming more popular. I’ll throw in a donation as soon as I clear up some bills. :smile:

I’m glad you’re enjoying it!

Don’t mess up your finances trying to help out. I’d rather you enjoy the site for free & avoid the stress.

Have fun out there!

Site let me log back in. Thanks James.

Fantastic!

I did some sleuthing & saw that I had bloooowwwwwn through my Strava limits, which caused all this trouble.
The underlying code doesn’t handle that situation well, so I temporarily stopped all Strava activity until their daily limit rolled over.
Sounds like things are back to normal now!

Hey there! Well, I had to login through a defunct MapMyRun account because I am having this same described issue with my Strava account. It shows that it cannot connect to Strava because it “cannot authenticate you from Strava because ‘Invalid Credentials’.”

I have been checking back periodically throughout the day and multiple times right after the hour to see if it was the described API limits.

I have also reset the password on Strava, and revoked access to reset the situation. I have also cleared out the cookies and history on both Chrome and Firefox and still have the issue on both browsers.

At this point, I’m at a loss for other potential troubleshooting options.

Thanks for all your help James!

Please - anyone reading along - do not deauthorize CityStrides in Strava (unless you want to quit CityStrides) because all this does is delete your data and add to the problem (your new account will need a full sync again, adding to the job load).

Yeah sorry, all we can do is wait.

API limits reset every 15 minutes and every 24 hours. These are two different limits, and it’s the 24 hour limit that I’m reaching now.

Because of the backlog that’s piling up during this period, I’m just hitting the limit again right after it resets. :frowning:

I’m discussing a rate limit increase with Strava, so :crossed_fingers:

Super important, so I’ll repeat:
Please - anyone reading along - do not deauthorize CityStrides in Strava (unless you want to quit CityStrides) because all this does is delete your data and add to the problem (your new account will need a full sync again, adding to the job load).

3 Likes

Yikes. I’m really sorry James, I had no idea. I appreciate your quick responses, fingers crossed that Strava follows through.

No worries! I haven’t found a good way to explain what deauthorizing does, and it’s so removed from the CityStrides site - since that action is taken within Strava - that I can’t put up a warning. :thinking: Maybe I can change the app description in Strava to include a “only revoke access if you’re quitting” note.

Sorry if I came across harsh. I just wanted to let others know that it doesn’t help.

Totally understood, and not harsh at all. Fortunately, it doesn’t look as though I was successful in deauthorizing after all, so there’s that.

It does seem like a challenging issue, especially since there’s no other way for a login to CityStrides, but for going through the third party (Strava). I don’t know how you do your job with all of us dimwits bouncing in and out of here! :crazy_face:

1 Like

Hey; I can’t log in with Strava today. Gives me “Invalid Credentials” error. I looked at a really old topic and it says it might just be the load…if that’s the case, I will just try again later.

This still isn’t working today…I get "Could not authenticate you from Strava because “Invalid Credentials” :frowning:

I tried on IE, Chrome, and on iPhone under Safari.

Yeah, I’ve completely blown past my Strava API limit … which breaks everything.

We just have to wait this out. :frowning:

I’m taking with them now about increasing my limit… :crossed_fingers:

3 Likes

Thanks! Getting so popular!

growing pains

4 Likes

Oh I see Strava’s end game. It’s about selling Summit to all of us!

1 Like

I spotted that my runs didn’t get loaded onto CityStrides and logged out of the website and then tried to login via Strava. Then I spotted the error.

Well, I just tried to login at 23.01 local time. No such luck. :grimacing:
But the only run missing is mostly off road, I don’t expect a new street being completed so I have time. :nerd_face::partying_face:

Having the same issue and now I can’t login to city strides :frowning: