Crashes constantly on iphone/ipad

Every time I try to load citystrides on my phone - it crashes over and over again? I paid for the membership - but now nothing loads?

Can someone assist?

Is this you? Chris's Map View - CityStrides

Depending on how much data you have (ie runs & GPS points to show) it could take awhile to load. I believe some of the data ends up getting cached for future loads.

Are the iPhone & iPad older models?
Are they on the newest version of iOS?
Assuming you are viewing on Safari on the devices. Do you have another browser on the devices to test with?
Try clearing your cache and loading again?

Hi Chris, sorry for the trouble!

I’m wondering if it’s related to your switch to a paid membership. When you become a supporter, a job is queued to build your LifeMap. There could be a bug where between the point of paying & the point that the LifeMap is built - things could fail. I’ll look into that.

I do have a list of questions that’ll help me figure out what’s going on:

  • Did the crashing start to occur after you paid for the membership?
  • Is it just one page that’s crashing, or every CityStrides page?
  • Is there a message that appears with the crash?
  • Which phone do you have?
  • Which browser are you using?

It crashed every time up until I paid for a month membership and then it stopped crashing and worked perfectly.

My month membership expired last week and now it crashes on every page again.

It just says “A problem occurred on this page and it was closed” it reloaded and crashes again over and over until it finally stops trying to load. I just tried it again and it is crashing again.

I am using an iphone xr with up to date software. It does not crash on the computer.

This is a huge pain with the non-supporter LifeMap.
The problem is that some people have lots of activities, and displaying all that data on the map can bog things down to the point that the browser/device cannot handle it. The amount of activity data that causes things to crash varies across devices, so it’s difficult for me to limit things in a way that avoids crashing and avoids me going insane working on the fix. :sweat_smile:

I was able to solve the issue in the advanced LifeMap by completely changing the underlying data structure. That change adds cost :moneybag: though, so I had to put it behind paid access.

Fixing this has been on my to-do list for a while. :confounded:

Ah, good to know. I paid for a month on a whim to see if that would fix it as I’d talked to several others who had the same crashing issues but didn’t realize that paying is what resolved it for them.

Thanks for the info!