Can't see any streets on my LifeMap

Hi, I just joined citystrides. I don’t see any streets on my LifeMap. Can you help?

Welcome to the community!

It looks to me like it was just a processing delay… I am seeing purple lines on your lifemap now.

Can you see them from your device?

I still don’t see the streets on my phone. I get an error message saying something went wrong :scream:

Hey Frank, your LifeMap is looking good to me on my laptop. Do you have another device to try?
You do have a lot of activities - I’m worried you’re hitting the limit for your device. :sweat:

I just upgraded to the supporter level. Let’s see if I can see my map on my phone soon! :smiley:

I can log in to a computer too. I’ll do so but it’s too late to open up my laptop :sleeping:

All looks well on my phone now. Looks like I got my $2 worth! :smiley:


Woo! (though it does bug me that there’s a weird data limit)

Be sure to check out the Supporter Features page to see what else there is for you to use!

Since the import of all the Australian cities several days ago (thanks @JamesChevalier ), I can no longer see my LifeMap. I’ve tried on an iPhone, iPad and windows laptop, all don’t act the way they did before.

This is weird … the map is erroring out on the data in your LifeMap and I’ve never seen this before. I’m going to need to look into this more…

Update: I have an idea - I think it’s because none of the cities in Australia have latitude/longitude values yet. I’ll update again as I learn more…

Update: OK - I’ve got a quick hack of a “fix” up now … your LifeMap won’t break, but it’s gonna dump you into the ocean off the coast of Africa. You can zoom out from there, pan over to Australia, and zoom back in. I’m going to correct the issue in the database, and when that’s done your map will no longer drop you into the ocean - it’ll center on your city correctly.

Update: All fixed. :sweat_smile:

1 Like

Thanks James. You’re a champion.

Hi, I just downgraded from being a paying member to a non-paying member, as I was not using any of the additional functions (e.g. nodes to make routes). However, now my entire Lifemap does not show on my phone, Ipad or laptop. Any ideas? Or does this have to do with my downgrades? Thanks!

My Lifemap

Your map displays for me:

This usually suggests that you have too more activities to display than your device can handle … but I took a look and there are only 43, so that can’t shouldn’t be it!

If you view your LifeMap from a private browsing window, does it work that way?

Please try going into your settings page … going into the Profile section … and clicking the button in Clear Map Data From Browser … then try looking at your LifeMap again.

Does the issue also exist on your view of Amersfoort?

Another thing to try is to log out of CityStrides and log back in. I’m not sure offhand why that would be required, but - in the interest of trying everything…

Dear James, many thanks for your suggestions. I tried in a new private window and clearing the map data but no effect. When looking at Amersfoort I see only the border line of the city limits, but not my own runs. I also tried logging out and in again a few times, but there was no change.

However, when I changed from Firefox to Chrome browser all my runs were visible again…!

I don’t know how that is possible, but perhaps something to look into?

Many thanks again, Rudolf

:thinking: a private window didn’t show your LifeMap?! yeesh…

The fact that it works in Chrome suggests it’s a browser data issue … but that button in the settings page didn’t work & the private window didn’t work (which is effectively the same thing as completely clearing your cache; I think) … which doesn’t suggest a browser data issue.

Are there any errors shown in the browser console when viewing your LifeMap?

  • Visit your LifeMap page
  • Open the Tools menu → Browser Tools → Browser Console
  • Click the trash can icon in the top left
  • Refresh the LifeMap page
  • Any red text?

When you tried in the private window, did you also log in or did you just try to go directly to the page as a logged-out person? That’d be two separate tests, which could help add more detail:

  • Viewing in a new private window, logged out
  • Viewing in a new private window, logged in

We could try to clear CityStrides data from Firefox:

  • Open Firefox preferences
  • Search for ‘clear’
  • Click the ‘Mange Data…’ button
  • Search & remove anything for ‘CityStrides’