100% complete streets showing as incomplete suddenly?

Hello - random one here!

I’ve got a bunch of incomplete streets popped up but when I click on them they’re all at 100% complete? Some examples below…

Screenshot 2022-01-12 165134
Screenshot 2022-01-12 165211

Any suggestions what’s happening here?



I’ve still got some funky cache situation to clean up. It looks like your page is displaying correctly again, though.

This situation - completed streets becoming incomplete for a moment - can occur if a city is updated from OSM in a way that adds new nodes & you’ve already completed them. When the new nodes are created, it’ll knock your percentage down. But all new nodes are processed, so that will mark it as complete again.

1 Like

I have have seen multiple examples of new nodes beeing added to a street that rightly takes the percentage down to under 90%. But the street is still marked as completed.

Is that a known problem?

One example:

It is now a known problem :sweat_smile:
It’s also super weird that it knows you’re 76% done, but still has you listed as completing it. I bet the percentages are being updated, but the record that is created when you finish it is not being removed. I’ll take a closer look later - thanks for reporting!

Thanks James - it has absolutely righted itself now! I hadn’t noticed the city had just updated which was why I seemed impatient - sorry!

It is indeed a known problem:

As far as I can say, the issue does not occur anymore with new updates (the user just has to wait a few hours until the calculations for the updated city are complete - I guess most are either a bit impatient or haven’t noticed yet that the update notifications come before the slow jobs are over) but there are streets that have not been updated for a year or more, and they can be marked as completed if they were over 90% at some point even if they are now under 90%. I have re-run most of the cases I was aware of (hard mode style) but I think I still have 6 of those.

If @pettersunde has examples involving recent updates, that’s very interesting because I probably check around 2000 streets/month and don’t have any.

It is still a problem. This is from the osm update at 2021-12-16. I usually find them and run them as well.

1 Like

I also have new cases. After months without this problem, I suddenly got 5 new completed streets with a percentage under 90% yesterday (February 7th 2022).
While other streets become incomplete in similar situations, these ones did not and I am unable to identify what causes this error and why it is not systematic. One thing is certain: @JamesChevalier has to check his code.

Ah, I see. The job that validates completed streets is running faster than the job that updates the node count for the updated street.

So it’s adding new nodes … and then validating existing completed streets based on the wrong node count (so it still looks complete) … and then updating the node counts.

One of the “perks” of a highly concurrent job system churning through 50m+ jobs/day :sweat_smile:


I’m still seeing a bit of an issue related to this after my city got updated recently. I know it’s normal for there to be a delay for processing so I gave it some time, but after 2 days it hasn’t updated. It seems it processed for some others in my city, so I’m not sure why it hasn’t for everyone.

Example where I have 100% nodes and it still shows as progressed and link to street shown:

Thanks as always for all the effort you put in James!

:thinking: share your profile link & I’ll push your account through an update

I’ve noticed it for other people in my city as well. Like, the leader should be much closer to 100% but he’s at 98%.

Alright, I just pushed everyone through. I think it’ll take some hours to finish, though - this queue is a little backed up right now.

1 Like

It’s still showing 100% completed and yet incomplete…. I believe you stated that you fixed it above but mine is not fixed:

I am seeing this today as well with one of my cities that updated today. It is showing six streets as “incomplete”, yet all six are showing as 100% of their nodes complete.

Thanks James. My issue has been resolved. As an FYI though, I see that some of the other people who have run the same city are also showing as less than 100% now, and when I look at their “incomplete” streets, they have the same ones listed that I did.

I’m having a similar issue with a street that should have moved to “complete” a few weeks ago

Bridge Street

I’ve run it a few times and been patient, but it appears to be stuck somehow. It’s not a new street and really shouldn’t have had any updates in OSM. Not sure what else I can do. TIA

For what it’s worth, this situation resolved itself. Not sure if the good people off this site did anything or it was just part of the standard update process. But it ended up being about a month after I ran my street to getting it marked as complete. Stuff happens, it’s a lot of data. And hey! Fourth city down!

I’m having the same issue as before after another city update. It seems to be affecting updated streets where I have between 90% and 100% and newly created streets I have 100%.

An updated street that is now marked as incomplete (link to street):


A new street I completed prior to the update but is not marked as complete (link to street):


An updated street I had 100% and is still marked as complete (link to street):


Here’s my profile again if you need. I waited a couple days again to see if the issue would resolve itself but it hasn’t even after a couple of runs. The bug seems to be affecting others in my city as well, based on the leaderboard.

Sorry to double post, but is there any way you could look into this @JamesChevalier? I have managed to hit some new nodes on the streets less than 100% which have completed those streets, but this obviously isn’t possible on streets I’ve already hit all the nodes. I know I could manually complete those streets, but I’m finally nearing 100% in my city and I’d love to do it without any manually completed streets. It seems like this will keep happening to me every update anyway.