Streets with 0 Nodes

Thanks James, I appreciate your quick response.

These streets were not showing a couple of weeks ago, so I think the update is recent. Do you have an ETI on when regular updates are going to start?

They’re currently ongoing: Now Testing: City street/node updates

1 Like

Got 14 zero node streets back in Elmbridge that I have 100% done (well without these)

Aissele Place
Ashley Drive
Ashley Park Crescent
Barrington Lodge
Cloister Court
Englemere Park
Esher Park Avenue
Irene Road
Little Orchard Place
Littleworth Lane
Nettlefold Walk
Pendenza

OK, so yesterday Lidingö Lidingö kommun, Stockholms län - CityStrides was successully updated, that is my additions from OSM are now visible in the street listing. But they all have zero nodes. Those are streets that were present in OSM, but without a name. I have now just named them: E.g. Abborrstigen in Lidingö kommun, Stockholms län - CityStrides
It’s shown in the map, a sido-road going west halfway down on Abborrvägen in Lidingö kommun, Stockholms län - CityStrides

Is this the right place to report zero node streets as got 14 (see above) that need clearing down to can get back to 100% again!

I only have 30 streets to go in my city but they all have 0-nodes.

Probably half of them I ran by now but 0-node streets cannot be completed.

Why is it that everytime I see this topic, I immediately flash back to the song by U2: Where the Streets have no Nodes?

Maybe I’m just old?

3 Likes

@fredrik.coulter Nice. That was the first album I owned on CD.

1 Like

Was going to make a bad pun but I’ll resist. I’m guessing the answer is ‘fix it in OSM’ but just because I haven’t come across this problem before, thought I’d run it by the forum first…what’s weird is the road is part of Benfica (in CityStrides and in reality), and does populate on the map, but why does it appear in the list of roads if it has no nodes…?

Curious about this too for 31 Alley in Durham, North Carolina - CityStrides

Potential good news: Updates on November 4, 2020

James thinks he has the 0-node bug resolved! Just need to wait for the next OSM update for that city!

4 Likes

@JordiMonge before that, I’d prefer some other issues fixed before such as showing a street as complete after completing all the nodes, mainly because it shows more nodes than the ones it actually has. E.g. Marlboro Way, Pleasanton, CA has 8 nodes, but it shows 29.@JamesChevalier any plans on fixing that? Thanks in advance!

Yes. This is discussed in a few different places - throughout Streets with 0 Nodes and possibly addressed in Updates on November 4, 2020

Thanks a lot @JamesChevalier for the fast reply. But is it the same issue streets with 0 nodes that streets with just 8 nodes but they show 29?

Same but different.

Both are issues as @JamesChevalier works through bugs in the city update code, the “8 nodes but they show 29” streets weren’t re-calculated when your city got updated and it removed the old Some Streets Contain Nodes Outside City Boundary nodes. I am pretty sure he solved that issue so those streets should be corrected when your city updates next (a few of mine did)

1 Like

Hi @jpbari thanks for your reply. I still think that the issue is not the same. The streets where I have the issue are in the middle of the city. Nothing to do with a street in the city boundary that extends to another city. It’s not a big deal marking them as manually complete, but as SW engineer myself, just wondering if these cases can help @JamesChevalier to fix another bug in the future :wink:

There have been a few bugs in the city update code along the way. Sometimes resulting in different outcomes - one bug resulting in either zero-node streets or mis-counted nodes.

Your city was last updated from OSM: 2020-10-08, which falls in line with the mis-counted nodes bug. I fully expect the next update to resolve that issue in your city.

1 Like

Thanks a lot @JamesChevalier for replying to all comments!

1 Like

Hi - I have 2 zero node streets.

Waterford, CT

Bolles Court, which I set to private road in OSM.
Northwood Road - I set the end section to private driveway in OSM. It got it right, but has the stray zero node.

Thank you!
Craig

1 Like

After the last update for Lipan (5/21/21), Hinkle Ct turned 0 node.

OSM did not have the gate on Hinkle Ct.

I added the gate, and marked the part after the gate private.

Seems to be a similar scenario to @crmerriman

Thank you!
Eric