Some street completion errors

Got some pesky streets showing up as incomplete in my city list (Kevin Pels - CityStrides):

Rua Luis de Freitas Branco - CityStrides (says 5 nodes, only 4 appear on map, all as complete)
Rua 1 ao Túnel do Rego - CityStrides (says 20 nodes, all 20 appear on map as complete

Relatedly, this one is marked foot=customers in OSM and was updated in CS; it appears in the Streets list for the nested city but not the parent city - shouldn’t appear in either :person_shrugging:

You have to be careful when comparing the displayed node count and the number of nodes you’re able to count on the map. Since I’m pulling in individual Way records from OSM, and combining them based on their name in order to build the concept of a “Street”, it’s normal to have multiple nodes at intersections.

I checked the data for both your links, and all the completed node records are there, so it didn’t create the completed street for some reason. I’ve started the job to fully recheck your account.

I’ve noticed some city update failures recently that I think are playing a role here. I’m going to take a look through that code to see what’s up…

Let’s see how the next update of that city goes. Maybe the update for that parent city got a different Overpass server.

1 Like

Yeah I’m not saying the nodes completed or not have anything to do with the street being done, clearly they don’t in these cases - just in case it would help diagnose what’s going on with the errors. Appreciate you looking into it!

More context if it helps - I think the errors occurred following me deleting some old activities that had GPS errors and reuploading corrected versions. The activities were the ones that originally completed at least one of those streets, Luis de Freitas Branco - but it was weird because I had re-run it later and didn’t delete that activity.

Streets no longer appear post-city update. Thanks and happy thanksgiving :turkey:

Hello !
It’s great if @kevincharlespels issue is solved.

I may be in the same case, in Paris (France) : after the last city updates (since 1 or 2 month), I’ve noticed that my completion score was decreasing step by step. But after a quick look, that seems (almost) not related to streets’ updates nor creation : some nodes are reappearing as “missing” (red) in some streets that are clearly already completed. You can see on the screenshots attached that there are already previous tracks through these nodes.
Surprisingly : these streets can appear completed in the “sub-division” nested in Paris (ex : “Paris 6e Arrondissement” Paris 6e Arrondissement, Île-de-France - CityStrides) but uncompleted in the “global” city of Paris (Paris, Île-de-France - CityStrides).
Do you have any idea about this issue @JamesChevalier ?


:thinking: spot-checking Route des Petits Ponts & Rue Scandicci from your first screenshot - all those nodes are marked as complete now.
Are things looking correct for you now?

Thank you @JamesChevalier for this 1st check.

In fact, in my first screenshot, streets ‘Rue Scandicci’ & ‘Route des Petits Ponts’ we indeed completed : the missing node is in ‘Avenue du général Leclerc’. You will see it better in the 2 following screenshots.

You can see that this ‘Avenue du général Leclerc’ appears completed in ‘Paris 19e arrondissement’ (which is nested in Paris) but not completed in ‘Paris’.

The fact that nobody was marked as having completed it suggests that this is tied to city update issues (I’ve since reprocessed it, which marked some people as having completed it). Avenue du Général Leclerc - CityStrides

For your own account - is it possible that you haven’t completed both sections of the street? There’s another section of it in the 14th: Avenue du Général Leclerc - CityStrides

(If you share more data, can you do so in the form of links? Those are much easier for me to work with, since it cuts out a lot of searching)

I can confirm James’s theory, you have not completed Leclerc in 14th arrondissement, so that’s why it’s not complete for Paris

Thanks for your inspection, James !
In fact, Avenue du Général Leclerc - CityStrides was probably a bad example, due to this dual section. In addition my issue is not such that the street is not completed : it is that some nodes are re-appearing as not completed, where they were completed before.
But something has actually changed after your reprocessing : the red nodes in that street have turned ‘completed’ (purple), now ! So it’s maybe juste a processing issue, at city scale ?

Just in case, another example in the same zone :
Boulevard Sérurier in Paris 19e Arrondissement Île-de-France, France appears completed with all the nodes completed,

Where Boulevard Sérurier in Paris Île-de-France, France appears uncompleted due to some nodes uncompleted even if I’ve ran them (we can clearly see a previous track).

Is it possible to try a global reprocessing of Paris, or something like that ?

Hello @JamesChevalier ,

There was a city update for Paris tonight… and my issue is increasing : I lost an additional ~0.3% of my completion score (~20 streets)… and I suspect this is still a processing issue.

For example, Boulevard dy Montparnasse was updated tonight: it now appears uncompleted in Paris even though I’ve run each nodes !

As you can see is the screenshot below, I have many red nodes (2 in that street, + many in the surrounding streets) although I clearly went throughthrough these nodes.

In addition, I’m relieved to see that I’m not crazy :rofl: : one friend of mine also have the same issue, meaning some streets will “false” missing nodes.

Example :

Do you have any idea about this issue ?
Of course, if I can help you to solve this, teel me how ! :slightly_smiling_face:


I found a workaround to “solve” my issue : I had to delete and re-import manually each activity into which I had at least one tricky node. That was not fun (between 50 and 75 activities I would say) but it did the job : I’ve recovered almost 3% of the city by doing this ! :white_check_mark:
I hope that the next city updates won’t affect this newly re-imported activities - we’ll see. :sweat_smile:

See you next year !

1 Like

Hello @JamesChevalier
I have a similar issue, with just 1 street in my home town of Otwock. The street name is Władysława Stanisława Reymonta and in one fragment of that street, 4 nodes re-appeared while it was completed before. Any chance you can have a look what may be causing this? Would deleting and re-syncing the activity (like JB did) help?
Thank you!

I strongly advise against deleting data as a “fix” for anything … The result may end up being that the issue you’re spotting is “fixed” but in almost every case the underlying problem can be fixed by me doing Something™ or all of us just waiting a bit.

If you can share links to the pages in CityStrides - city page, and one or two street pages - I can likely sort this out.

Sure, here you go:
City page - Arno S. is running Otwock, województwo mazowieckie - CityStrides
Street page - Władysława Stanisława Reymonta - CityStrides
(for now it’s the only street I noticed with this issue)

Thank you again for your responsiveness!

I have solved this problem by walking the street again :smiley:

1 Like

Was looking at my incomplete cities list and noticed the issue described in my earlier post is still outstanding: Some street completion errors - #2 by kevincharlespels

The Way record it’s pulling in is Way: ‪Praça de Armas‬ (‪781501738‬) | OpenStreetMap

The query is filtering on ['foot' != 'no']
…also ['access' !~ 'customers|no|private']

So this Way is correctly syncing into CityStrides based on the query.

It doesn’t look like the key foot has a possible value of customers but the key access does mention it. I’ve updated the tag on the Way record, so that will be fixed up in the next update.

1 Like