Site down June 2 (and June 10)

Same here.

Missing activities from today 2 June

Sync now leads to an error page.

At 12:44am Eastern, the server that holds all the job data ran out of memory. I have code in place to prevent this, but I forgot to include it with the recent Challenge release. I’ve fixed this issue & also increased the size of that server a bit.

I’ve started a sync for each of you, @itsafrogslife @petje @klaasjanelzinga
Sorry for the trouble!

3 Likes

Been deleting individual activities to fix GPS trace and replacing them for over a month, but had a few problems recently. Today’s issue is that I can’t delete this activity: https://citystrides.com/activities/19803287 - whereas normally, I’d get the corner popup noti letting me know my activity is scheduled to be deleted, now I get the spinning wheel and the page letting me know “Waiting for www.citystrides.com…” before finally…

And so here I am!

Getting the same message when trying to load the Status page, so I’m guessing there is a sitewide issue at the moment.

Yeah, you can try again now.

1 Like

having issues with my latest run dated 02/06. get an error when i try to manually sync and also get an error when i use the ‘sync now’ feature. Grateful for any help with this.

Hey Gareth, you can try again now - there was some site downtime that caused your ‘Uh oh.’ message.
I moved your post into this thread, to contain the single topic of June 2 downtime. Your other issue - where I transferred the post from - has not been resolved & we can talk about that issue over in that thread.

My activity from Strava this morning still doesn’t show in CS. Will it resolve itself, or do I need to make a Sync Single Activity?

Thanks that’s worked now :+1:t2:

You should sync the single activity … For existing users, anything from roughly 12:44am to 9am (Eastern) that’s missing is going to stay missing unless a manually sync is done.

Yes, had to wait a while, but now it’s all there!

Hi @JamesChevalier Thanks for the update and the quick fix!

All good now :slight_smile:

Sync now doesn’t seem to be working for me again. I get the oops message. I’ve tried manual sync and it said it was successful but the activity isn’t appearing

I have the same issue this morning too (June 10th) with sync giving the oops message

1 Like

I have the same issue, status page and “synch now”, everything else seems to work.

My run today ( 2 hours ago) hasn’t appeared yet. Site doesn’t seem to sync at the moment. Server problem?

I had the problem today (around 7am EDT, 10 June), but it has resolved for me and my morning run has synced.

Yeah, looks like the issue started at roughly midnight Eastern / 4am UTC. It’s the same issue as June 2, but I think I actually figured it out this time.

The core issue is that too many Challenge processing jobs were queued, saturating my job database memory, bringing that server down. I thought I found where I was doing that after the June 2 issue, but there were more places that I was reprocessing Challenge progress (e.g. activity deletions).

@gijs.smets try a single-activity sync, from your settings page, if it hasn’t arrived yet. This may fail - I’m actively working with Garmin support on the exact failure, so if it does fail know that I’m already working on it.

1 Like

Thanks @JamesChevalier my activity has appeared now :+1:t2: