Red Nodes on Completed Streets

Hi there!

I am walking in Oakland CA, and noticed that many of the streets I had previously completed now have red (incomplete) nodes, and the streets have moved to my “incomplete” tab. My path cuts right through the middle of these nodes, and the incomplete nodes popped up many months after I had completed them! I’m sure this is just an OSM/syncing issue, but Oakland was just updated the other day, and this problem remains.

Does anyone else have experience with this? Here is a screenshot to show you what I mean.

Thank you for your support! Please let me know if you need any additional details.


Do you know roughly when these nodes started appearing as red?

I’ll look into cleaning things up now…

Edit: This might be fixed now - you’re down to 1388 incomplete streets. I’ll just need you to confirm if things look all good now.
(I’d still like to know roughly how long they’ve been incorrectly red, though.)

Hi James!

Yes it’s been fixed, thanks!

I would say about 2 weeks. Not sure when it first appeared, there didn’t appear to be an update that caused it. I do know that Oakland was just updated the other day, and the problem persisted.

Appreciate the help and response!

I’ve noticed something similar recently, streets completed long ago are suddenly incomplete. At first I thought someone hade made a change in OSM that caused this, but I can’t see any change. Then I realized that my gps track for those streets where quite off, so I was “lucky” to get them completed anyway in CS. So my initial guess was that something had changed in CS algorithm pushing them out of scope, that is, maybe a node was 29 meters away from the track and was accepted then, now suddenly it’s 31 meters and not ok, so red? Or CS’s margin of error changed? I have a couple of such nodes since last update May 5, and I also saw that my friend Benny has several of them. Link Hans Westerback is running Norrmalms stadsdelsområde, Stockholms län - CityStrides

:thinking: The distance cut-off hasn’t changed. These nodes are validly incomplete. It does look like they were created on May 4th, in the last update.

Here’s a specific example: Node: 11873745949 | OpenStreetMap
I think this may have been a newly created Node in OpenStreetMap.

I’d guess, in this case, that the data was edited in OSM in a way that … de-completed the street for you.

Hi James,
This just happened to me. Red dots just appeared on a street I completed last week. There were no nodes before as this is a street that was recently developed (but I ran it anyway).
Should I run it again? Or, will it correct itself later on?

I’d need more information in the form of links to answer that … Specifically, a link to the activity that should have completed the street and a link to the street itself.

If I have that, I can check the data to see if nodes should have been marked as complete and were not.

Thanks James, here’s the links:

Activity: Mario Villemure 's activity on May 3, 2024 - CityStrides

Street [Sullivan Dr]: Sullivan Dr - CityStrides

Interestingly, the nodes appear only when I am on my callenge map.
Challenge: …challenges/421

Yes, now that I look closer I think I understand why this happened. I know this street has not really changed, so why would there be new nodes? A user has entered a lot of parking conditions in and around Stockholm, and to place these he has entered new nodes in the middle of the blocks. So when I ran with a crappy gps it looks like I swerved off quite a bit in the middle of the block, where there were no nodes,so completed the street anyway. Now with the new nodes I’m no longer complete. Same thing for e.g at Kammakargatan. So we just have to go back, now with a more reliable watch :grin:

Oh, so this is Challenge specific?
It sounds like something caused the activity to not get processed for your Challenge. :thinking: I just reprocessed the activity for the Challenge & the street is now marked as complete … Do things look correct now to you?

It’s all good now! The nodes have disappeared.

Thanks James! Keep the great work, you are awesome!

I have this same exact issue in Oakland. Completed the street in Oct 2021, with the recent, I think as of May 4th it’s showing as incomplete now.

If you share links to the activity and the street (it’s fine that the activity is private, I’m just looking at raw data), I can check if they’re now validly incomplete (like what happened to Hans) or if some processing didn’t run as expected.

Experiencing the same issue here. Large amount of the issue streets were on this one run (linked) but there are 8 other outliers that appear to be from other separate runs.

Thanks in advance!

I was able to find the activity in CityStrides - 2Hoyt2Handle's activity on August 2, 2023 - CityStrides

The street I happened to pick, Appleby Street, had some odd things going on… The site noted 4 nodes, but there are 6 … and it hasn’t been touched since January of this year.

I ran some code to validate your completed streets (also ran it for everyone else in the city), and I reprocessed that particular activity. That dropped your incomplete street count down to 122.

Very much appreciated. Cheers.

Activities on previously completed streets:

CityStrides - This one seems like the map was modified and might not line up where the actual trail is but at least some of the nodes are red where my route goes right through them or at least close.

CityStrides - With the exception of one node which maybe got moved on Panoramic way, my route passes through the rest of the nodes which are all showing as incomplete.

CityStrides - Route appears to go through all the nodes that are showing as incomplete on Norfolk Rd

CityStrides - Route is seemingly close enough to a missing node on Grizzly Peak Blvd in Oakland. Have a separate activity that is even closer to the red node.

Hey James,

Looks like the same problem popped up again, after Oakland was updated earlier this morning! The same nodes and streets are red once again, even though none of the streets with missing nodes were involved in the Oakland update. This is so weird! Attaching the map again. Let me know if you need anything else.



I just reprocessed your account, let me know if there’s still incorrect data being shown.

Back to normal! Thanks again James.

I don’t know why this keeps happening after updates, always with the same nodes!