Recent run with no streets progressed (July 7)

I have one run on July 7 that is still not showing any progressed. Should be some completed, too. Is there still a delay getting some older activities updated?

I’ve noticed that streets from my previous run are only turning from progressed to completed when I record my next run and in turn those streets sit in progressed purgatory until I run again.

Thanks for this added detail. I’m aware of this issue, overall, but this helps me see the underlying problem a bit clearer.

I hope to have this sorted out soon. First I have some sync issues to wrap up.

I ran an hour ago, and already have completed streets! Nice work.

Update: I ran earlier today and within 30 minutes it had updated my previous run and that run.

Alright, I’ve change some stuff around with the way that the system determines street completion…

It used to queue up a job 20 minutes after the activity was created, which would do that street completion calculation. The expectation was that all the coordinates for the activity would probably be processed within that 20 minute timeframe, even with a large load.

Now, the last coordinate is created in a way that identifies it as ‘last’ in the activity & after that has been processed it triggers the street completion job. So the expectation here is that the timeframe between creating the activity and calculating street completion will be much more directly connected. For the most part, this should mean that completion appears on the site faster - if it only takes 1 minute to synchronize the activity then we won’t be waiting the extra 20 minutes any more.

Everyone’s feedback will be really helpful here - do you notice street completion appearing faster/slower? Do you see any activities where no completion is noted (e.g. I’ve totally screwed all this up and broke it more instead of fixing it)?

Thanks everyone!

Hi James, my run yesterday shows my progressed streets, but not my completed streets. (The streets I complete are not listed at all–not in progressed or in completed.)

I think I see the trouble… It looks like you might have completed these streets in previous activities.

I checked out your map & saw Mondrauteweg.
So I clicked through one of your progressed streets, then clicked through to the city, then clicked on the Streets tab & searched for ‘Mondrauteweg’.
This brought me to the street page.
I checked out the Runners tab & saw that you are listed, with a completion date of July 26, 2017.

Perhaps all those streets in your activity that aren’t listed as progressed/completed are actually already completed?

Thanks James! I checked that I thought should have been completed yesterday, and they were indeed already all completed. It was for sure my first time ever running on Bulachweg, Bärlapweg, and Eduard-Mörike-Straße, which were the ones I was expecting to see as completed. I guess they were already marked completed based on my having run “close enough” to them in the past (?)

Yeah, the system marks streets as complete if you have run 90% of its nodes. It might have marked it as “done enough”. :smile:

I think I have a similar problem. My run yesterday doesn’t show all the streets completed, but when I go to the city page today, the missing streets from the run are now listed under the “Streets Run” column when they definitely were not fully completed before yesterday.

Examples of streets completed but missing from the run: Elmore, Janet, Alderwood, Burrage, Glendale, Loring, Wessex, Garner, Nottingham, Francis, Westbourne, Reed

A couple of those are dead ends, so I know I haven’t completed them in previous runs. :slight_smile:

:thinking: Elmore displays you as having completed it on May 24, 2017.

:poop: In my update 2 days ago :point_up: I omitted a (as it turns out) very important ordering in one of my database queries. So the completed streets have been associated with a random activity over the last couple days. I’m releasing an update now that fixes this going forward.
The existing street completions will remain associated with the incorrect activity, unfortunately.

I am experiencing a similar issue. For one of my runs (but not the last one), I have 0 completed streets, but the streets individually show up as ‘run’ in my Lifetime map. I am sure I did not run these streets previously.
It looks like this activity was left out of a ‘counting’ job, but included when processing the city.
run = Rutger Mooy's Activity on September 10, 2017 - CityStrides