Not detecting streets I ran 100%

Hi! As far as I can see there is a slight GPS difference in my run and the map. I did run the street as seen in my activity but CityStrides doesn’t see it because it thinks I ran through the houses. :joy:

You can spot them for example in the two bumps in the northern part of my run here:

That activity is private in CityStrides, so I can’t view it.

Are the GPS tracks in CityStrides the same as in Strava? Or are they shows in Strava one way and in CityStrides another way?
I need to understand if the activity is somehow ‘broken’ in CityStrides… or if it’s GPS jitter that’s causing CityStrides not to see a street as progressed/completed.

Sorry James, I didn’t realize I had my activities private. This one’s public now.
The data is also like this on Strava so my guess is the GPS was a bit off. But if you see the line one could imagine the streets being run.

I’ll check my other activities of they also have this problem.

Had the same thing happen to me on this activity:

If you look at the map view in CityStrides, it looks like I ran through the wilderness. If you switch to satellite view, my run path lines up with the street - however, the street name is now going through wilderness. It displays the same in Strava & CityStrides, so guessing it is a mapping issue, not a site issue.

There are other streets on this run that show on the map, once you switch you satellite view, you can see the “street” goes through someones living room, or simply does not exist. I am guessing some of the street data has not updated, after plans changed?

I see that that activity now has 12 progressed, I think something has changed. :slight_smile:

Ah, thanks for sharing that - makes it much easier to debug! :smile:

Here’s the updated link, because the original post cached the inaccessible page:

It looks like there’s some decent progression/completion in there. If you click the names of the streets, it’ll show you the nodes for that street (I need to fix the cursor behavior to indicate that those are clickable buttons) - are there any progressed streets that you think should be completed?

:laughing: Yeah, I had a massive backlog because of a bunch of new signups. It looks like it just caught up. :+1:


I have the same issue where a street that I ran down doesn’t register. It’s not on the list of streets either. Probably a mapping issue. The street is Newlands Road in Lancaster, UK.