Node Hunter not working in city view

Clicking the Node hunter button makes the red ‘X’ appear to get rid of it, but no nodes appear. I can make the nodes appear by clicking on my missing streets from the list in city view. Node hunter does still work in Lifemap mode.

For me, it works but has been quite slow compared to previously. James mentions in the Sep 15 update that he has worked on this, so maybe it is better?

I’d say not at all for me, 30 secs+ that I’ve waited at a time. Meanwhile individual streets to view nodes works instantly. I wouldn’t be surprised if it was related to the update, I only saw that post after mine and thought about reposting it there but figure James will move it if it’s related to that. Still not working for me now 4 hours later.

EDIT: While I was typing the comment the unfinished nodes appeared. I did it again while looking at my watch and took ~50 seconds. I can’t believe that this is how it’s meant to work now…much prefer how it worked before, didn’t even realize it was something that needed to be improved.

Unfortunately (at least for me), I’m now getting a console error when trying to load at full default city zoom level. Previously it took about a minute to load missing nodes of 10 remaining streets. Now after ~a min, console reports:

P.S. Cleared my cache beforehand to load clean new data

This must be related to the changes in Updates on September 15, 2022 (Release 621)
The fact that showing/hiding streets works is a bit confusing, because a large part of the underlying changes were in that area.
I have monitoring in place, and it’s showing some of these Node Hunter requests are taking minutes :sweat: with none of them taking over 2min.

  • Thanks for the comment noting that the nodes do eventually appear, that’s helpful
  • I’m also interested in which city you’re having this issue (a link to one or two may help, even if it’s every city in your experience)

Can you clarify whether the slowness you experienced was before or after that Sept 15 release?

No, it’s definitely not expected behavior & I’ll be working to fix it. The reason I’m working on this at all is from Show incomplete streets - #11 by ward_muylaert and some conversation above that post, where people were experiencing minute+ waits when using Node Hunter.

Thanks for sharing the console error. Basically, it looks like the previous version was taking a long time (about a minute) and this newly released version is taking even longer (status of 524 is a timeout).

I just updated the code to revert some of my recent changes. I’m interested in whether this improves things… Ideally:

  • Close the current tab you have CityStrides open in
  • Open a new tab and navigate to your city page
  • At any zoom level, click Node Hunter
  • Wait for nodes to appear, generally noting the time it takes (doesn’t need to be accurate)
  • Click the X to hide the nodes
  • Zoom/pan to a different section of the map & click Node Hunter
  • Wait for nodes to appear, generally noting the time it takes (doesn’t need to be accurate)

I’m looking to see if it’s overall faster, and whether the second request is even faster still.

1 Like

Wasn’t working for me either one or two hours ago, but it seems to be OK again

1 Like

The ‘city’ (really, a rural area with multiple small villages) that wasn’t working was Fontes, Santarem, Portugal: Fontes, Santarém - CityStrides Was especially concerning because this area only has 116 streets and only 12 are incomplete for me, so I figured it shouldn’t be slow at all compared to some larger Node Hunter tasks.

I did just re-test it at the total area level and it took <10 seconds now with your reverted changes. To my eye still slightly slower than before, it was usually instant, but much better than the 45+ seconds I was getting before. Zooming in closer to a very localized area it took <5 seconds.

I noticed some slowness prior to Sep 15 update, but I can’t be definitive about that.

Just now I went to a different city, did Node Hunter, and it took 11 seconds to bring up nodes.

Did what you suggested above (go to different part of city, etc). Took 7 seconds.

I can’t really say if it has gotten better/worse for me pre- or post- Sep 15. :person_shrugging:

I’m running another test now, if you bop around with Node Hunter in a similar re-test now are you seeing basically the same performance or a bit better/worse?

Thanks for testing. Your timing could be getting in the way - you may have just missed the bad code that I released on Sep 15.

2-3 seconds now for similar test.

Heading away from computer now, so won’t be instantaneously responsive next time. :grinning:

1 Like

~8 seconds for all of Fontes, ~2 seconds for zoomed in area. Again it’s better and I don’t want to complain too much, but it was more or less <5 seconds before as far as I remember–as in, if this took 5 seconds before and now takes 8 I wouldn’t make much note of it, but when something goes from really fast to not really fast, it’s noteworthy.

Tested the whole of Stockholm, six seconds. Zoomed in a bit, now three seconds. Zoomed out to whole city, three seconds. Looks very good to me!

Yeah, it’s looking like the requests that were the worst/slowest are faster in this version but the fastest/okayest are a little slower. :sweat_smile:
I’m not confident that I’ll be keeping these changes around.

1 Like

Alright, this is back where it was before the 15th. :slightly_frowning_face: I wish that worked out better, sorry for the trouble.

1 Like

Always appreciate you trying to improve the platform and being responsive to feedback!!