No runs showing up from runkeeper

Hi, I’ve just joined and the site has claimed it has started syncing. However my profile just shows “0 activities” under runkeeper despite there being plenty there and the app being hooked up and given permission. Do I just need to wait it out or is there a problem? There’s nothing atm to indicate that anything is happening.

Yeah, there’s a bit of a wait while activities sync over. There was also an issue this morning with the sync not actually happening - you might want to try the “sync now” option in the menu…

Came here looking to see why my activities might not have sync’ed after linking to my RK account. It might make sense to trigger the equivalent of the “Sync Now” action automatically when an account is linked?

It should be doing that automatically, so I’ll need to look into why that didn’t happen…

I just linked to MMR and that synced immediately, but earlier with RK I had to prod it. (FYI in case there’s a difference somehow.)

OTOH I tried to link with Strava and clicking that Connect button ( gave me:

{"message":"Bad Request","errors":[{"resource":"Application","field":"redirect_uri","code":"invalid"}]}

I have a big issue with Strava that I’m working through now where I’m hitting their API limits, which causes all sorts of problems (activities not syncing or partially syncing, login failures, etc).
I am releasing a quick change now, which might help a little, but I’m still working towards a full fix - I hope you can have patience with some little bugs until that’s finally done.

Hi. I joined a few days with a Runkeeper account. My profile shows 0 runs, no data is loading. Any suggestions on what I should do?


It’s happening for a lot of people right now. I think it’s mostly Runkeeper folks (like me too). In one of the other threads he says he hopes to have the problem fixed this week.

Have you tried asking Strava for a higher API limit based on the number of users using City Strides? Apologies if this is something you’ve already considered!

That’s where the webhook thing came in (mentioned in some threads around here) - so new activities are automatically synced individually right after they get created in Strava. This is one of their requirements before increasing limits. I’ll get in touch with them again, since that hasn’t solved the issue.

Awesome! I hope they are receptive to the request :-).