Missing queued Strava activities still missing

That revoke in MMR does not seem to work as mentioned in my last email.

I have tried several times on several browsers/devices. Is it supposed to send some sort of message to CS so you can update your database?

I don’t have any activities in that account so, in that sense, does not matter hugely but be good to clear them all down as you can with say Garmin.

Looks like the other one (the one I deleted) is clearing down as can see my street count has really dropped back. Seems you clear the streets done and then delete the activity.

Looks I will be able to start a sync with Strava shortly then to build it all back up again.

Thanks again.

James - all the MMR activities are still there albeit all with now zero completed streets.

Do you need to delete them now in the database? I can’t obviously resync yet with them there.


Actually I wondering now if I should disconnect from Strava, let me delete, reconnect and start off as if I was a new user? It’s just that the Strava ones I do have might need to re-processed for streets?

NO please do not do this!
There’s a TON of data to delete - it’s going to take time.
If you disconnect Strava, then you have to wait for all that to delete too - this will only add pain.

Anyone reading along: the answer to any issue is NEVER to disconnect the service. Disconnecting services deletes all that service’s data - so the ONLY thing this helps with is leaving CityStrides.

Oh OK - I haven’t and won’t then.

I can see some of the maps on the MMR ones have gone so presume it is still deleting?

I guess it is running as a batch job and processing when it can?

Phew! Glad I caught you :smiley:

Yeah, deletions are kind of “expensive” in this database. To lessen that load, I have to work in small batches. It can take quite a long time.

Thanks for your patience!

Think the resync has more or less completed. I have 5486 activities in CS. Strava says I have 5729 run activities and so not included Virtual Run etc etc

Would you filter out runs with no GPS data - like say manual entries? Mind you I don’t think I have more than a handful of manual entries.

Anything else? Anyway of telling easily what has not synched?

Just checking my LifeMap seem to be a few missing

Tim Grose's Activity on November 8, 2013 - CityStrides looks OK - no streets added as looks whole run was on private roads but it used to be on the Life Map. Have done other runs in here and they are not showing either so let me check for them…

Yeah this one too Tim Grose's Activity on May 11, 2016 - CityStrides which does include public roads.

Actually those 2 missing ones have now turned up on the Life Map. Still trying to work out how can be sure everything has synched though?

@JamesChevalier - I have a few runs queued from Strava for Sept. 18 and 19 that are not showing up on my LifeMap. When trying to add manually, CityStrides let’s me know they have been queued; however,I haven’t seen it take this long previously. Thanks for all you do!

Here are activity URLs:

Strava syncing has recently gone bananas.
I don’t see a huge influx of new users, but I’ve suddenly got 11k+ new activities and 32k+ historic activities to sync. These push API usage above my limits, and it’s very difficult for me to properly display that in CityStrides

It’s strange because up until 3 days ago, I’d only use 20-35k API calls … then suddenly I’m using all 130k/day

I’m temporarily disabling all historic syncing & I’ll monitor the new activity count for when I can re-enable that.


OK the tldr; on this is update is: I’m an idiot
You can stop reading here if you don’t need further info :rofl:

Back on the 18th I updated my error catching code in a way that also caught expired token issues - I usually handle those by refreshing the token & carrying on with the sync, but my update handled those as if they were Strava errors. I handle those by scheduling them in the next API cutoff (a long-ish term try again). :man_facepalming:
This means everyone that’s missing an activity (these tens of thousands of activities) are just circling the queue → attempting to sync → getting an expired token error → re-added back to the end of the queue. :grimacing: :sweat_smile:

I’m releasing a fix which reverts to the correct behavior. I’ll keep the temporary history sync paused while the 12k new activities get synced into CityStrides. I’m expecting this to take 2-4 hours. I’ll check back later today, and if those activities have synced in I’ll allow historic syncing again.

:musical_note: sorry :notes:

Update: The queue has been completely worked through, so there shouldn’t be any missing Strava activities from the 18th → today


I have three activities missing, James… September 20 to 22. I had yesterday´s.

I just confirmed those are in the queue (after I started a “sync now” for your account) & should arrive within ~15mins

Hi James. As usual, thanks for your great work on this site! My strava activities on September 19, 20, 21 and the 22nd are still not showing up on city strides.

My activities from September 23rd to today have been showing up! Here is my citystrides: Sam Johnson - CityStrides

Here are those activities:

Thank you. The entries come up on my activities and increase the percentages of the streets accomplished but they are still not showing up on the Life Map yet. Not sure if that will happen or a glitch?

I’m missing an activity from Sept 20.

Hello Profile - JamesChevalier - CityStrides Community

I still have 9 missing activities from Strava since September 20. I can see it’s a very common problem. I hope it’s a matter of patience…

Thank you

Same issue for me none since 9/21, I know its just a patience thing, no worries