Minor, slightly annoying issues with Route/Route Builder

When I finish a route and save it, and navigate to the newly created Route page, the blue dotted Route Builder line still appears overlapping with the blue solid line of the route itself (hard to see until zoomed in). The dotted line also stays on the LifeMap. The only way to clear it is to reopen and either start a new route or reclose Route Builder, which means clearing the “are you sure?” dialog box. So, two issues:

  1. That confirmation is useful when you actually have a route in progress but otherwise just makes and extra click. So would it be possible to make it so the confirmation alert doesn’t show up if you haven’t started a route? Or put another way, only triggers if a route is in progress and hasn’t been saved yet?

  2. What’s going on under the hood with Route Builder that makes the saved route stay on the subsequent Route/Lifemap pages? See below screenshots - first is of the completed route, second is a newly loaded instance of Lifemap with the route still showing up (Route Builder not open). Not the biggest deal in the world but I would think this isn’t intentional, and I’ve been dealing with it in the aforementioned manner.

Thanks for sharing all this!

The first item, confirmation when closing Route Builder even when it wasn’t used, will be fixed in the next deploy.

The second item is somewhat purposeful. It’s also going to be fixed in the next release (clicking the “View” button will remove the drawn/dotted version from the map), but there are details here that I think are useful to share.

A) You can start creating a route on any page … navigate through the site to any other page (including navigating through pages that do not have a map displayed) … and continue building your route. That’s expected/intended behavior.

B) Clicking the “View” button takes you to the individual Route’s page. That page has some JavaScript that forcefully closes Route Builder, but currently fails to throw away the drawn/dotted version of the tracked route & this persists throughout subsequent page views because of the previous intentional use case.
(Again, the next release will cause the “View” button to also remove the drawn/dotted route path)

This does leave an intended behavior… You’ll be able to create a route, click the Save button, and navigate throughout the site with the entire Route Builder UI staying present (including the dotted/drawn path) until/if you visit that specific Route’s page in either way - via the “View” button or by navigating to Routes → that route page or you click the button to disable Route Builder.

:sweat_smile: :nerd_face:


Perfect. That’s what I’ve been doing, clicking “View” when I’ve saved my route. And what you’re saying makes sense when the bugs are resolved. Thanks!

As an additional aside I have noticed if I go to another page that has a map and the route in progress sometimes I cannot resume route building. In the screenshot below the route was started on the Route page (Trilho do Rio Tinto); switch to Lifemap, still editable; go to Routes page, select the original Trilho do Rio Tinto Route page and this is what I see:

Don’t really know if this is a problem since you wouldn’t be changing pages a bunch with a route in progress, but if you misclick while building you might lose your progress depending where you navigate to. Could be especially annoying on mobile where it’s easier to accidentally reload the page…

Ah, yeah, this would be a gotcha with the fact that the individual route pages forcefully turn off / disable Route Builder.
:thinking: I’d need to do a fair amount of re-thinking to resolve that … probably moving all the logic that does the disabling out from the route page and into the “View” button itself. I can’t guarantee that’ll make it into the next release, but I definitely should do that, since it would be the least surprising behavior.

1 Like

Can’t believe how quickly this was deployed. It’s a minor, but very appreciated fix! One less click is like less than a second saved, but it’s noticeable and makes the experience incrementally better. Good suggestion @kevincharlespels, good fix @JamesChevalier !

1 Like

Noticed it too when I designed my route yesterday, forgot to circle back and say thanks as well :slight_smile: