Manual sync blues

Context: Since my GPS data is always so crappy and I got sick of deleting/reuploading activities, I no longer automatically sync my runs from Garmin to CityStrides, and instead upload the edited .gpx files to Runkeeper. Then I go to my CityStrides and press “Sync Now”. For the past few months, this has worked great!

For the past couple weeks, can’t remember precisely when, I no longer get the friendly and helpful green popup bubble confirming that I have a sync in the queue. That gives me agitation about whether or not the sync request went through, even when the URL changes to https://citystrides.com/users/15559/sync_next, because the sync/processing seem to take a variable amount of time even when there is no delay for either supporter sync/processing on the status page. For example, this morning I was waiting more than a couple hours after pressing ‘Sync Now’ and the unprocessed activity only just appeared in my list as I was typing all this out. Other times it’s more or less instantaneous.

Anyways, it’s just a bit frustrating since my experience doesn’t seem to align with the status page. Hoping this information helps you clean up any issues in the manual sync process in the next releases.

I’ve got a catch-all queue for various jobs & this has been oddly backed up lately. I suspect this could have some part in the issue, but I’m not certain it’s entirely to blame.

The fact that the notification doesn’t pop up, and the fact that you’re taken to that URL (I changed your quotes to ticks, to disable that URL - I generally make a point of not editing any posts in this forum, but that link is not useful for anyone) … this suggests to me that the link is not working & your activity is syncing along with the normal flow of things (CityStrides polls Runkeeper, since they don’t have any alerting set up).

If you try choosing “Sync Now” from the menu now, does it still take you to that new URL? If it does, can you try refreshing the page while holding shift & trying again?

Sync now does still take me to the same URL, but nothing on the page changes (unless I’m on LifeMap, then all the purple lines disappear). When I refresh the page with that URL in the navigation bar, it brings me to my homepage.

Not sure if you have a Garmin watch, but if you have, did you change settings to “Every Second Recording”, cause Smart Recording is really bad for CityStriding.
https://support.garmin.com/en-US/?faq=s4w6kZmbmK0P6l20SgpW28

I did at first and have gone back, because more recordings = more timepoints to move around when the GPS drift is so insane. In the cities I live(d) in, it has not helped with accuracy.

Any updates on this @JamesChevalier ? I uploaded a walk earlier in the day which seemed to get fetched/processed relatively quickly (<0.5 hr), but been waiting more than a couple hours now on a run. Could multiple sync requests in a single day be part of the issue…?

Edit: this is the activity that I’m still waiting on this morning Track your Run - ASICS Runkeeper™ Running Tracker App

There are two moving pieces here:

  • There’s recurring code in place to sync every Runkeeper account once per day, if you happen to finish your activity after that then it will come in during the next sync (the next day)
  • There seems to be an issue with the “sync now” link for you (I cannot reproduce this issue, I’m unsure if anyone else has similar troubles)

It does look like your activity made it in: https://citystrides.com/activities/27670778

The behavior of clicking on that “sync now” link in the top right menu should be:

  1. You are taken to a URL ending in /sync_next
  2. You are immediately redirected back to the page you were on
  3. The green box appears in the bottom right, letting you know it worked

The time it takes for steps 1 & 2 should usually be so fast that you cannot tell they occurred. I don’t have a very large budget, though, so things aren’t :sweat_smile: always the fastest. :grimacing:

I’ve changed the “sync now” link a little - let me know if it’s working correctly for you now (basically, hoping it doesn’t leave you at that /sync_next page).

1 Like

Thanks for looking into it again - very odd that this problem is peculiar to me, although I guess I might be uploading my activities in a slightly idiosyncratic way… I can confirm that steps 1-3 are how the behavior went previously, but how it has been for me currently is that I stay on the /sync_next URL and steps 2-3 never occur. I miss that lil’ green box.

I just tested the “sync now” button and now I do not see the /sync_next URL, nor the green box, so that’s different. If I didn’t notice the page reload I wouldn’t know anything happened at all.

Also, the activity you linked to (3.04 mi walk) was one that did successfully get in earlier in the day, but not the same as the runkeeper activity I linked (6.64 mi run). Still waiting on that one going on 24 hours

:thinking: This ‘sync now’ behavior odd, and if this link just worked for you then we’d at least be able to move on with manual syncing (which most Runkeeper users are likely doing now anyway, given there’s no ‘push’ from them).

I’d like you take some steps to see if we can debug this:

  • visit your profile page
  • refresh the page while holding the shift key, because computers
  • open the browser console
    • Firefox: Tools → Browser Tools → Browser Console
    • Chrome: View → Developer → JavaScript Console
  • open the top right menu & select “Sync Now”
  • screen shot or copy/paste the contents of the console in a reply

I’m hoping something is happening in there that will be helpful.

Might be on to something…?

(also at some point between now and my last post the 6.64 mi run synced & processed :man_shrugging: )

:thinking: nope, that “Refused to load media” message is from some tooling I use (and is removed in their next release).

If you click on “Network” (just to the right of Console, in the top right of your image) … refresh the page … and then click on “Sync Now” … :sweat: and then scroll to the top of its list … does it show that “synx_next” request’s response as a 302?

Yep:

Not sure if you changed anything, but manual sync just worked instantly this evening! First time in a while that I uploaded an activity, hit Sync Now (still no green box), refreshed the page and saw the activity added on my profile page, mid-processing. :grinning:

As an update - for the past few days everything working very smoothly with ‘Sync Now’, still no green box, but importation and processing of activities is occurring in < 1 min! Thank you @JamesChevalier !