LifeMap disappeared

I have recently joined and my back sync is currently progressing. My map was expanding fine until yesterday, and now suddenly I see no purple lines at all. Is this something which will right itself, or is some specific action needed? This is the link to my profile:

I have been looking at the LifeMap regularly as it expands with the back history going in. A new (i.e. recent) activity uploaded yesterday, which I edited, not sure if this would have affected anything.

I moved this over to a new thread, because the other thread is only for supporters (they have a different LifeMap).

Your LifeMap is appearing ok for me:

Do you have any other devices to try with?
Also, can you try on the same device but in a private/incognito window?

I’ve seen some devices fail to show the LifeMap after a certain amount of data to display. That’s usually number of activities, and you’ve got under 100 - so I’m not expecting that to be the issue … gotta test everything, though. :slightly_frowning_face:

Hi James, thanks very much for getting back to me so promptly. The LifeMap you are seeing, pictured above, only shows my public activities (currently 38). The back sync is now complete (back to Dec 2014) and I have 1207 activities in total.

I am using a desktop computer. If I look at the map (on the same computer) when not signed in I see the map of the public activities, the same as you. Hope this is of some help with the diagnostics.

Usually when this happens, it’s because the device can’t handle displaying so much data. It’s part of the reason I built out New: LifeMap performance & filtering for subscribers

Are you familiar with browser developer tools? If you can open up the Console and refresh the page, it might show helpful errors.

I opened the LifeMap in Firefox with the web console. The salient bit seems to be the line which starts “XHRGET,15676415,…” followed by a lengthy sequence of 8 digit numbers. It ends with: "[HTTP/2 414 Request URI Too Long 971ms] ".
I also tried in Chrome, but the map still didn’t display. I tried a Samsung tablet with Chrome and it DID display. I tried my wife’s laptop with Chrome and it didn’t display, but it DID display with Edge.
It seems that some device/browser combos work and others don’t. Hope this is of some help.
Edit: the map HAS now come up on Chrome on my desktop!

1 Like

Ah! 414 Request URI Too Long is good to know! I can work with that…

In the meantime, you might be able to work around this issue in Firefox by visiting the CityStrides website … opening Tools → Web Developer → Storage Inspector … expanding Indexed DB … expanding the entry for CityStrides … right clicking on the entry for citystrides (default) and choosing delete.
:flushed: :sweat_smile: :grimacing:

The bug here seems to be around how I try to optimize requests. If you have no local data, then I have it request all activity data. If you have some activities already cached locally, though, I have it request only the activities you don’t have.
It sounds like there’s a big issue with:

  1. visiting the LifeMap right away while your activities are still syncing
  2. leaving, maybe going for a run or just generally having a life outside of CityStrides (weird, I know, but some people do this for some reason)
  3. coming back after a lot / all your activities have synced

Maybe I can change that so it checks how many new activities are needed. If it’s above a certain number, it can just request all of them.
:thinking::man_shrugging: I’ll think of something

If you try resetting the local storage in your browser, let me know if it helped.

1 Like

I deleted all my browser history, which didn’t seem to make any difference. I then tried the steps you list to delete the citystrides (default) entry and presto! The map appeared!

I’m seeing the same 414 errors in Chrome. I tried Firefox and that worked without any developer tools interventions.
My subscription did just lapse. I was using Chrome before and it worked. Now that I’m not a supporter, it doesn’t work. Maybe something was cached in Chrome that’s not present in Firefox since Firefox only knows me as a non-subscriber?

The non-supporter version has an upper limit of how much data can be displayed for some browsers/devices. Unfortunately, it’s different from device to device & I’m not sure that I can know ahead of time if the amount of data that’s going to the browser will work out or not - so when it doesn’t work, it fails. I’ve also been wary of the idea of only displaying (random example) the past 6 months of activities in non-supporter LifeMap - partially because that would be taking away existing functionality & partially because there are browsers/devices that get by just fine with lots of data (and also partially in the hopes that I can fix this issue).