LifeMap crashing on iPhone

I’m a new user on CityStrides, and I’m really excited to hit every street in Walnut Creek, CA. The LifeMap works great on my computer, but about 90% of the time that I try to view it on my iPhone, it crashes. I get the error message "A problem repeatedly occurred on… I get the same error message if I use Safari or Firefox. Basically, what happens is the map tries to load, gets hung up, reloads, and then gives me that error message.

I’ve looked through old forums on this issue, and it appears that there might be a corrupted track that is causing this problem. Thanks for the help!

I can’t reproduce it, because your activities are private. That’s ok - no need to change your privacy settings!

Does it work properly if you visit the beta ( Beta: LifeMap performance )?

If it does work properly - do you see a square with an X through it here?,-4.319127608810504&4.464277395631693

If you don’t see the square/X, then the issue is probably that you’re running too much. Have you considered sitting on a couch, or if this is an extreme case, just staying in bed? :laughing:
But really, the map does fall apart after a certain amount of data is added to it - which is why I’m working on the beta. I want to check with the Mapbox team about this, though, because they claim to support handling large amounts of data and I don’t think any of us are throwing that much at the map :man_shrugging: maybe we are.

Thanks James for the quick response! I have changed my settings to public, since there was no reason that they needed to be private in the first place.

When I try the beta version, I get a map of Walnut Creek with no activities displayed. However, if I turn on the node finder, it correctly shows me the nodes that I have yet to complete.

Thanks again for your help.

Try again now - I ran the job that rebuilds the beta map for your account. I’m able to see your LifeMap beta. Your regular LifeMap does show up for me, eventually, but it’s slow enough that I can see the possibility of it crashing some browsers.

Another potential issue with the LifeMap beta is that the browser tends to cache the tile data (your tracks) so clearing cache or trying another browser can help. I haven’t figured out a consistent fix for the browser cache issue yet.

Thanks James. I still am not able to view my tracks on LifeMap on my phone using the beta version (using either Safari or Firefox), but the nodes show up, which is all I care about when I’m actually out running.

Oddly enough, when I attempt use the regular LifeMap in Safari, it crashes after 2-3 times attempting to reload the browser. In about 10% of instances, it will actually display the map correctly.

However, when I do the same thing in Firefox, it continually reloads the browser until it actually seems to display the map properly. I let it go at it this morning, and after about 12 times reloading, the map displayed correctly.

ugh. mobile browsers are tough to debug.

Do you see different results while logged in vs logged out (via private/incognito mode is probably the easiest way to test that)?

Thanks James. When I run LifeMap via private mode on Safari with my iPhone, I get the same behavior as I do with the Life Beta Map. That is, the GPS tracks of the streets that I have completed do not show up, but I am able to view the uncompleted nodes. In private mode, Safari doesn’t crash, it just doesn’t display my GPS tracks completed.

:thinking: It doesn’t display any GPS tracks for you? Or is it not displaying certain tracks within your otherwise visible map?

My confusion is because I’m seeing your LifeMap beta in general (I can’t be certain about whether or not any activities are missing):

When I use the LifeMap beta, it doesn’t display any GPS tracks using either Safari or Firefox on my iPhone.

Oddly enough, after installing the new iOS update (13.2.3), the LifeMap beta on my phone now displays the GPS tracks properly. No idea what was going on before, but I’m glad that it’s working correctly now. Thanks for all of your troubleshooting efforts!

1 Like