Garmin login never completes

No particular error message, just the loading symbol that never actually loads. I’ve walked away for several minutes with no changes/progress and have tried logging out/in repeatedly. Strava lets me in just fine, but I would really rather continue using Garmin.


I ran a sync, but am still missing my Sept 26 activities, so I’m not entirely sure what’s going on there. I assumed they were related, but could be totally wrong! It’s happened before :slight_smile:

Thanks, that’s a helpful screen shot - it helps me understand where in the login flow things are going wrong.

Can you take some debugging steps for me?

  • Log out of CityStrides, if you’re logged in
  • Visit https://citystrides.com/users/sign_in
  • After you’re there, open the browser’s console:
    • For Firefox:
      • Open the Tools menu
      • Open the Brower Tools submenu
      • Select Browser Console
    • For Chrome:
      • Open the View menu
      • Open the Developer submenu
      • Select JavaScript Console
  • With that open, click the button to sign in with Garmin
  • On that “Connect with CityStrides?” page, click the button to connect your account
  • Wait for the spinner to appear

I’m wondering if any new errors appear after clicking the button to connect your account on Garmin’s “Connect with CityStrides?” page…

Sorry about getting back to you so late!
I wasn’t able to open the menu the way you recommended, but I was able to get this far. Here’s the latest screenshot… Hopefully “helpful”… or something?

Deleting both your CityStrides and Garmin cookies fixes that issue so it must be something related. Or, go into an Incognito browser and login from there…