Can't unpin a city

:link: My profile link : Jakub Šimek - CityStrides

Hey, I’m trying to unpin Vršovice (nested city within Prague}, but it’s not disappearing from my pinned cities, even after refreshing the page.
Clicking the button sends a request to https://citystrides.com/running_cities/45918582/unpin and gets a 204 back.
I’ve tried with other cities that I have pinned and they all worked fine. Also I’ve unpinned completed cities before and don’t remember any issues.

It looks like I block un-pinning your default city, which can be updated in your Settings page. I just have it early-exit instead of giving any helpful feedback :person_facepalming:

1 Like

Ahh, that makes sense. I forgot the option even exists :slight_smile:
Thank you!

1 Like

Gonna piggyback on this topic: Unpinning a city shows no UI indication that it succeeded.

After changing my default city, I was clicking the “pinned” icon, and it was giving me no feedback. Later refreshed and realized it had correctly unpinned.

Thanks for bringing this up - that UX is trash :sweat_smile: because it only adds/removes the city to the pinned cities list & doesn’t provide any UI indication within the main list of cities (where the actual button is).

The next release is going to wrap that up by making the pin/unpin buttons also update the button icon. In the unpinned state, the pin icon is at an angle & in a pinned state, the pin icon is straight down.

1 Like