Activities not syncing when duplicated in strava

I run with both RunGo (for direction) and a Garmin watch (as a back up for when phone battery fails. Recently I have noticed that my Strava account posts a group run for those routes, showing two runs at once. When I see duplicate runs for the same run, those runs don’t show on Citystrides unless I manually sync through the missing activities forum page. The Garmin goes to Strava, then from Strava to CS, as always. I have not connected RunGo to Strave nor do not upload my RunGo activities if Garmin events are successful. I was wondering if this is related to the Garmin connect/balance updates. Thoughts?

I moved this to a new topic because it sounds like a new/different issue.

To be sure I understand correctly: you are tracking your activity with RunGo and Garmin, and both services are sending their data to Strava. Correct me if/where I’m wrong.

Again, to be sure I’m understanding: The services each create a new activity in Strava, which is the same data. When this happens, the activity doesn’t appear in CityStrides.

I do not understand this part. In the top right menu subscribers have a “Sync Now” option for you to sync your account if the automated process doesn’t work for some reason, you shouldn’t need to visit the forum for this. (Garmin/MapMyRun/Strava all alert CityStrides of new activities, so in theory you should never need to do anything to get those activities into CityStrides)

Have you considered skipping Strava altogether? You can visit your settings page in CityStrides & connect your Garmin account directly, then pause Strava syncing.

This confuses me as well - I’m unsure how you can have duplicate activities in Strava if you’re not sending the activity to Strava.


  • How frequently does this “activity not syncing” issue occur for you?
  • How long as this issue been ongoing?

I’m wondering if the duplicate data in Strava is a red herring.

Thanks for the response. You have most of the info correct. I have been running years with CS and this has never happened, so I am wondering if the issue started when he Garmin connection option started.
I use RunGo to create turn-by-turn direction for routes; the app also records the run in my log book, but that log book is not linked to Strava (or at least I didn’t do it - I checked the setting for that app and it does not look to be connected). If I need to, I can export a run to GPX file and upload to strava, but even then, Strava never didn’t create the group run issue. I use this app as a backup b/c I have been know to leave Garmin at home or to forget to unpause. I know the RunGo app is showing up in Strava b/c of the name it generates for the route, I just can’t figure out how it gets to Strava.
The real issue is that runs that runs that show up in Strava a group runs don’t appear in CS. I ran yesterday morning, Strava thought it was a group run, no CS activity. I ran last night, only Garmin connect pushed to Strava, so no group run, CS shows that run. It is odd.
Again, this issue has only recently started, and only occurs when Strava thinks these are group runs.
I will use the Sync now feature rather than the forum link.
I will try the Garmin connect only option tomorrow and will pause Strava to see what happens.

If your Strava activities are public, can you share a link to a Strava “group run”?
I’m wondering if those activities are tagged/categorized differently. I only sync types: Run, Hike, Walk … so maybe they’re something else in Strava.

Which forum link?

These are the Strava links to the two runs that show as group. Same route…I only ran it once, but Strava shows two.

https://www.strava.com/activities/4100786794

The ‘forum link’ that I referenced is the link to post missing activities. I have not had much need to do that, until lately.

Just noticed that both runs now appear on CS profile, reflecting both posts on Strava. The map, however does not reflect either. Thanks for checking in this.

I think the maps now match what’s in Strava…

Strava: https://www.strava.com/activities/4100786794
CityStrides: https://citystrides.com/activities/15586286

Strava: https://www.strava.com/activities/4100777183
CityStrides: https://citystrides.com/activities/15586285

I hadn’t actually gotten around to doing anything, yet, so it seems like some kind of sync delay…
:thinking:

This might be related to the recent Strava sync problems. After you reset things and announced that the queues had drained, I had to do a “sync now” to get anything converted. My map still hasn’t updated with them after a day or so, and I have an activity with 0 completed/progressed that I think should have a few (but was going to use the map to double-check :slight_smile:)