A lot of the functions don't seem to work on Safari

but are fine on other browsers eg Chrome. Is that normal or am I doing something wrong?

I’ll need way more info to help with this - exactly which features etc

It’s surprising to hear because I use Safari as my main browser :slightly_frowning_face:

Yes, I use Safari on Ipad and Chrome on PC, and haven’t noticed any difference?

I am on a MacBook Pro with an M1 pro chip and am using Safari version 15.1. The latest version uses a private relay which prevents tracking across websites. CityStrides can produce a listing of the roads I have run on but goes blank if I ask for a map. I do sometimes get error messages on other sites saying I need WebGL installed but this one doesn’t.

:thinking: I have these privacy settings enabled in Safari 15.4 as well

Are there errors in the JavaScript console? Please take care not to share anything that mentions “private”, in the unlikely case anything like that shows up.

The missing WebGL sounds like a decent lead. The maps are from Mapbox GL JS, which uses WebGL. I’ve never had to do anything extra to have this present, so I’m unsure why it wouldn’t be available in your Mac.

Update: I do see some JS errors in my error tracker. I’m trying to understand them now, and I’ll post again when I have an update.

Error: Failed to initialize WebGL

Thanks - yes the WebGL does look a likely culprit. I used to get the same error on my MacBook Air and was hoping it would disappear when I upgraded to the MacBook Pro

OK, I found something that could be helpful - I’m a little (pleasantly) surprised that a wikihow page was helpful as well :laughing: 3 Simple Ways to Enable Webgl - wikiHow

  • Safari Preferences → Advanced → check the box for Show Develop menu in menu bar
  • Develop menu → Experimental Features → WebGL 2.0
  • That WebGL 2.0 needs a checkmark next to it, so select it if there isn’t one

I don’t know if you need to restart the browser or not…

Thanks very much for all your research. Unfortunately when I checked, I already had the Show Develop menu and under Experimental Features, Web GL 2.0 is already ticked. I have tried restarting Safari too. I think I will need to speak to Apple.

I have updated Java but that has made no difference

Found the solution here right down at the bottom How i got Safari to have enabled WebGL ag… - Apple Community

For people who migrate rather than do a clean install we sometimes get unwelcome things transferred over including in my case a hidden message to disable WebGL dating from when it was WebGL 1. If you search for a file called com.apple.safari.plist and delete it (to be safe I moved mine to the desktop) the problem is completely solved. Problem is I don’t know what else I have thrown away in the process!

The map in CityStrides now works perfectly. I have spelled it all out in case someone else has the same problem.

Thank you very much James for all your help with this - I really appreciate it