23 "incomplete" streets but map shows all green

Just finished running all the streets in my 4th city (Colleyville, Texas), but have encountered a problem that did not occur with the first three cities that I completed. The map shows all green nodes, but the list says that 23 streets are still incomplete. I’ve attached a screenshot showing all these “incomplete” streets. As you can see, all the nodes are green, not a single red.

Most of these streets touch the city boundary, so I was thinking that perhaps it’s an issue with streets extending into neighboring cities, but there are a couple of isolated streets right dab in the middle of the city with this problem.

Other runners have completed these streets, but this was prior to the last OSM update on 2020-10-10. I’ve even tried re-running some of these streets thinking perhaps I missed an invisible node, but no luck.

2 Likes

This is a known bug that is being worked on. Basically, the city update code that was recently rolled out would occasionally exit early leaving the street count off. It should be fixed the next time the city update code is run on your city.

The reason this didn’t happen before is that the city update code rolled out initially a few months ago. (You might want to check the cities you’ve already completed. New roads might have shown up.)

3 Likes

Thanks - I’ve got the same issue with Islington, which I’ve very nearly completed!

Hi @johnkleighton , what happens if you click the “Go” button on those streets? I suspect you will be placed in the middle of the ocean (AKA the “0 node” problem) for some , if not all. This is what @fredrik.coulter mentioned. I would click the “Go” button on all streets, and check them one by one. Sometimes the street has two pieces that are miles apart on the map. If the others are in the sea, then you are in the same boat as me, and the next update from OSM should fix the problem.

1 Like

Looks like I have the same problem for Craven, UK. Being a rural area it isn’t uncommon to run a street in one village and it not complete because there’s another street in another village by the same name. This wasn’t the case this morning when I ran 7 streets or so that showed as 100% complete but were just showing as progressed rather than complete. Clicking go just focuses on that street and all nodes show green. I just manually completed them.

1 Like

@joel.dalby If you post a link to the street, I’ll bet someone could shed some light on it.

Thanks @ericjrw. I’ve just looked and the streets are showing as completed now (automatically). This is one of them https://citystrides.com/streets/10899588.

@joel.dalby That’s great. I was going to say wait a bit, but it seemed the wait was enough, but who knows. Every once in a while things do take longer than usual. Sometimes there is useful info on the status page: https://citystrides.com/status too.

1 Like

My ones that are all green, when I click on go, it just goes to the Islington street, has all the nodes in green and says 100% completed - but still shows under incomplete under Islington. Must be affecting my percentage too as it has me at 96.02% when in reality I’ve just got one street I accidentally missed on Tuesday. There are a couple of private streets too (which I’ve amended on OpenStreetMap) but that shouldn’t drag me down 4%.

How often is the OpenStreetMap sync? It says Islington was last updated in October.

This was what I was looking for. I just finished my 2nd city, but it’s only 99% complete because of two streets with this problem.
One is 0 nodes and in the ocean https://citystrides.com/streets/5725051
And the other is 10 nodes, but only 5 shows, they are all completed, but the street is not: https://citystrides.com/streets/5724907

It seems like they are correct in OSM.

So, if I just let it be, it will be fixed on a later update? I would prefer not to have to complete them manually, it feels like a first step to cheating :stuck_out_tongue:

1 Like

This city was last updated on October 22. There were bugs in the update code being used then that may have been removed.

Hang out and wait for the next update.

1 Like

@Lenka (Lenka), I feel the same way about completing manually. I believe I have run all my streets in Keller, but have 10 with the 0-node problem.

I’m siding with @fredrik.coulter, and just waiting for the next update… Which have started back up.

But, as an FYI, any manually completed streets should clear when the update runs. IDK if anyone has seen that, and that’s kinda why I’m holding off on the “manually complete” button.

OK, great, thanks for the replies and clarifications!

I’ll just let it be fir now then and continue with the next city :+1:

@ericjrw, I manually completed a bunch of zero-node streets for one of my cities and when it updated a couple of days ago my ‘manually completed’ total dropped to zero so it worked for me.

1 Like

@tamworthslim Very cool. Thank you for that info. I’m going to wait for the next update to my city, and if that doesn’t complete it, will manually update.

The city (Colleyville) was updated and now I’m showing 100% complete. Thanks!!!

3 Likes

@johnkleighton, very cool to see! Hopefully Keller is near the top of the queue.

Note for others: Colleyville and Keller are right next to each other, geographically.

Hooray, Islington has been updated and all my green streets that were showing as incomplete are now complete! BUT - there is still one ‘street’ showing as incomplete, but it isn’t a street! It’s this one: https://citystrides.com/streets/10739189. I tried to edit it on OSM a couple of weeks ago and made the alleyway leading to it private. But where the nodes are on CS show on OSM as a ‘highway feature’, not a street, so I don’t know how to edit it so it doesn’t appear. I don’t think it even exists as City Cloisters any more anyway - on Google Street View it shows on one view as ‘196 City Cloisters’, but in reality (as in - me looking at it with my own two eyes this Sunday) and on the next view on Google Street Map, it just shows now as ‘196 Old Street’. So really it’s just a gated driveway and someone’s back yard! So I don’t know why it’s pulling onto CityStrides or how to edit it on OSM so it doesn’t. @JamesChevalier - can you advise? Thanks!

1 Like

Hi Lizzy, If you look at the tags in OSM it is ‘Highway = Service’ and it has a ‘name’ so Citystrides will include it.
I think that if you edit it by adding a tag using the ‘+’ button under the other tags and choose ‘Access’ as a new tag and set it as private. That should fix it for the next update.
This is a guess as I’ve never done it this way. The only things I’ve ever set as private before had the dropdown options of All/Foot/Motor Vehicles etc. But they change the same ‘tag’ which I think is what James’ overpass query looks for.

2 Likes

Thanks, I’ll give that a go. Annoyed I didn’t do it before the update though, or I’d be on 100% now!

1 Like