Strava Authentication Error

Recently signed up and subscribed. Great tool, thanks @JamesChevalier
No problem connecting and syncing to my Garmin account. When I went to add Strava to pick up historical runs I got a “Not found. Authentication passthru.” error. Tried with Garmin sync paused, signed out and back in, and also from mobile and desktop versions. No luck. Thoughts?

Did that error occur when you initially clicked the “Connect” button in your Settings page, or did it occur after allowing access within Strava?

When I initially clicked the “Connect” button

:thinking: That button is working ok for me right now (Mac with Firefox/Chrome/Safari) - it takes me to either the Strava login page or the Strava page where I have to allow access.
I’m going to ask you to try again in a new browser tab … and I’m going to feel really bad asking you to do this, because you’ve already mentioned that you logged out/in which should have accomplished what using a new browser tab will accomplish. :confounded:
Can you also share your OS and browser info?

Nothing to feel bad about! You responded straight away and are helping problem solve the issue. That is awesome :grinning_face_with_smiling_eyes: I get to the Authorize page, then when I select Authorize I get the error. I did try this with either allow or not allow access to private activities just in case. Am using Edge on Windows 10. Also tried with Safari on iPhone. Will try with Chrome on Windows 10.

Did you work some magic?! Just tried again, and worked! Now syncing.

So weird!
All I can guess is that there was an issue on Strava’s side, and my code was quietly “handling” that error by displaying the message to you - but not reporting it up to my error tracking service.