Nodes No longer appearing on the Map

When running a street, the website used to say which nodes made up a street and whether they were completed. Apparently that feature was removed because I no longer see it. It was really helpful to to see where I still need to run to mark the street as complete.

I don’t recall removing that :thinking:
Can you share a link to a page that’s doing this (er, not doing this)?

Also, it has not logged recorded any of the streets that I ran on today either. That might be related as well.

That’s weird. If you click on the street names on the left, that should bring up their nodes in the map. I haven’t been able to recreate the nodes not appearing yet…

Additionally, if you click the ‘Check it out’ button in the popup, that should bring you to the individual street page which should also show the nodes. Do the nodes display for you there?

Taking one of my runs for example, clicking ‘Mountain View Drive’ and ‘Steiger Road’ should display their nodes. Does that work for you?

When I clicked on Alexandria Street, it did zoom into the street. It did not show nodes (as displayed above). When I clicked on “Check it out”, I still was not able to view the nodes. It does show the street at 50% complete though.

I can’t see the nodes on your streets either.

I remember it displayed last week, so not sure what changed.

Not sure if this is related, but new streets run aren’t even tracking with my latest runs posted today.

I should be more specific. The new streets run now appear on the “lifetime map”, but are not tracked as “streets progressed” or “streets completed” even though I ran in a city that appears in the database.

Yeah, I’m working through a huge backlog of activities that need to be reprocessed… it’s holding up a bunch of other work, like this completed/progressed identification. It’ll all get sorted out soon enough.


Ok, sorry about that. New rule: wait a day or two (at least) before panicking about any such issue and pinging the forum :wink: Thanks!


Yeah, two days is solid. For now - that’s another thing I think I need to clean up… caching is great, but caches that get stuck for two days are not.

I have noticed the same behavior recently using Google Chrome. If I paste the same URL for a street into Firefox I can see the nodes without any issues. I also see the nodes when looking at streets on my phone (Android)


That could be it. I am using Chrome. Haven’t tried any other browsers yet to verify that this is a Chrome issue.

1 Like

James should sticky this fact: In certain browsers, on certain computers, nodes or even the entire map display may not work. I have to use Safari at home because on Chrome the site works but NONE of the mapping works. Similarly, clicking on a street sometimes shows the street nodes (green and/or red) but on some browsers it doesn’t work. Try another browser and see if you get better results! For me Safari works the best but nearly crashes my computer (actually I think the citystrides websites burns up memory, and Safari makes it worse).

:unamused: :pensive: :confounded: :weary:
It sounds like I need to do more/better browser testing than I have been…

I’m on a Mac running Chrome, and things have been working for me. I need to get a list of OS/Browser instances that need extra help, so I can be sure to test those too…

I will start a “UI Issues” thread where people came share their info/troubles… if it grows too much from there then I’ll think of something else to do…

I started the new thread:

Btw, Nodes are now showing up again. Thanks for taking care of this!

Yeah I can’t see them either.