GPS dead spot? Any ideas?

I just completed a run where streets progressed and eventually completed. Nothing wrong there.
However, three nodes didn’t change or register despite my map going straight through them.
Screenshot 2020-10-07 at 20.26.59
The nodes in question are for Grand Arcade, which no longer an arcade but the pathway of a shopping centre. My GPS probably dropped in here because its notorious for lack of signal. Is this why they haven’t changed?
If that’s the case, how can I complete them? Any ideas? I’ll never not have signal in there (would connecting to the shopping centre WiFi work?).
It’s still technically a pedestrian walkway, so should (probably) remain in CS.

It’s all about the individual GPS coordinates that your app creates, and how they compare to the nodes.
Internally, CityStrides is iterating over the GPS coordinates from your activity & looking for any nodes within 25m to mark as complete.

That’s a really straight line going along Grand Arcade. Maybe there’s only one GPS coordinate on either end, so there’s nothing within 25m of either of the 3 red nodes.
If you share the link to the activity and to the Grand Arcade street page, I can try looking at the data to see if that’s what happened.

Ah ok, yeah that’ll be the case. I think it registered my GPS point before I entered the shopping centre and once I left it the other end. So there probably isn’t a GPS point in the middle, because I doubt my watch had signal.
My activity : https://citystrides.com/activities/15850044
Grand Arcade : https://citystrides.com/streets/10658776
Maybe I’ll try recording an activity on my phone using the centre’s WiFi, that should work?

I don’t think turning on the wifi will work. If this were me I’d mark it as manually completed.

I’ve had a similar experience with GPS creating a straight line between two GPS-recorded points with ‘GPS dead zone’ in between. This was when I did the Mersey Tunnel 10K. However, because the road isn’t normally runable there weren’t any nodes to miss.

Yeah, I had to increase the distance to 53m before picking up any coordinates from that activity

I know that most/all phone GPS is wifi-assisted, but I don’t know the technical details of that. Personally, I’d mark it manually completed and then add an #ideas post about an alternative/rebuild of manual completion to allow people to associate an activity to a street … so rather than just a blind “manually completed” it would actually associate the data, making it look like the GPS actually worked like it was supposed to. :man_shrugging:

1 Like

Actually, I thought that pedestrian walkways that weren’t also roads were not being included in CityStrides at the moment. That would be the same treatment as trails, etc. (OSM does not do as good a job with pedestrian walkways and trails as it does with roads.)

Thanks for all the advice. I’m trying to hold off manual completion for any streets and either figure out a way to complete them or edit OSM if it’s bad data.

I don’t know if using WiFi or simply using Strava directly on my phone that worked, but I went back today and managed to grab all the nodes. 100% completing that nested city.

2 Likes