Completed streets not marked properly

:link: My profile link :

Good morning all. It seems CityStrides didn’t process this activity correctly. I’ve tried downloading the raw file in Garmin Connect, deleting the activity in City Strides, Deleting the activity in Garmin connect and then reimporting it, but it didn’t work.

I can now see many of the streets that should have been marked completed show as still incomplete, but they don’t have any missing nodes to run.
Is there a way to reprocess that activity? Or will I have to go and run it again?

Thanks in advance,


1 Like

In case it helps track down what’s happening, it seems like I have the same issue from my activity today. I ran many streets, but CityStrides currently says there are 0 completed. On my Profile page, it says there are also 0 progressed. When I go into the activity, it says there are 27 progressed. On my LifeMap though, there are no nodes that remain to be completed on the vast majority of the streets. My activity from yesterday did not have this issue. Also adding my thanks for working on this.

For what is worth, somebody on CityStrides side very quickly reprocessed the activity somehow, and now it shows 14 completed streets :clap:
Now the activity shows correctly, and when I open the city it also shows the correct tally.
However on the Pinned Cities it still shows the incorrect tally, I suppose that will refresh at some point during the day.

For me (link to profile) the problem persists with todays walk. First there were 12 streets progressed, out of witch 6 were actually completed by looking at the points but said 0 completed. Some of those streets I marked manually completed and now those have disappeared from the street list under activity completely (total 9 streets). But now it shows some streets completed that actually have incomplete nodes on them. Haven’t had this kind of problem before, today is the first time but I’m quite a new user anyway.

Same issue for me this morning. I count 12 streets completed (they even show as 100%), but only got processed as “progressed” not completed. William Ashley's activity on May 3, 2023 - CityStrides

Furthermore, on my dashboard page that activity shows also as 0 progressed, even though on the details page it lists 24 progressed.

I’m decently sure that you & whoever else is saving activities right now :sweat_smile: are running into a delay in the background job system.
I imported a lot of new cities late yesterday, which has kicked up a lot of processing work. This is delaying things overall - it looks like it’s generally a 2hr wait from the time that processing starts (when the activity arrives in CityStrides).
I’m about to scale up the infrastructure to speed this up, which should somewhat quickly reduce that 2hr wait.

Update: It’s down to a ~30min wait

Update: Should be completely resolved now


I noticed the same thing today. I went out to complete 1 street. I hit all the nodes of that street, but it is being marked as “progressed” and still incomplete even though I got all the nodes. Once processing resumes, will this self-correct or did I need to re-run this section another day?

It updated…now it shows as complete. Yippee.

Maybe I didn’t complete all 50, but certainly managed more than none!

You have to have a little patience! Whenever something looks strange like this, wait for 24 hours! If it still isn’t correct - then it’s time to ask here!


Your comment just stopped me posting to say my percentage hadn’t been updated. Thanks Hans :+1:
Patience is a virtue, but I want it now!

A post was split to a new topic: LifeMap doesn’t fully draw at all zoom levels