Westport, CT border needs adjustments in OpenStreetMap - need help

It looks like a massive number of streets in Westport, CT: Westport, Connecticut - CityStrides have been deleted or are not being recognized as proper streets in City Strides. Very strange. There are no nodes associated to dozens of streets. You can see my activity from today in which I ran across many new streets but only 1 is showing up as completed: David Krulewich's activity on May 18, 2022 - CityStrides

The net total streets for Westport, CT is much smaller than the actual number of streets in this town. Something is definitely off. I checked OSM and all the streets are showing up as residential roads.

@JamesChevalier

Edit from Jim: The border has been edited in OSM in a hugely breaking way … This border needs to be fixed here: Relation: ‪Westport‬ (‪4139426‬) | OpenStreetMap

Are you seeing street records in CityStrides that have zero nodes? If so, can you share links?
Or are you just expecting to see more streets in your city?

It does look strange, if I check Westport (where I have never been :blush:) in Node hunter there are no red nodes in quite a big area. E.g Overlook Road

I’m seeing STREETS that have zero nodes. As to whether they are technically ‘street records in city strides’ - I’m not sure how to check that. But please refer to @hans1 post as he posted a photo of the issue.

Yes, it looks like for some reason the entire “Old Hill” neighborhood was skipped.

As a non-local, I kind of expected to go to OSM and find it marked as private, but it is not.

Looks like an import error of some some sort. The streets and nodes just don’t exist in Citystrides.

I’ve queued up an update for that city, let’s see how things look after it switches from Updated from OSM: 2022-05-18 to Updated from OSM: 2022-05-20

In the incomplete/complete streets listing, you can click the show/go button. If the street records existed in CityStrides and had zero nodes, you’d click the ‘show’ button and nothing would happen or you’d click the ‘go’ button and be taken to a page without any markers displayed on the map.

It may be helpful to understand that the map visual is one set of data that Mapbox provides & I have no access to, and the lists and markers displayed on the map are an entirely different set of data that exists in the CityStrides database.
:person_shrugging: or it may not be helpful at all :laughing: in which case you can somewhat safely ignore this :grimacing:

Still the same. E.g. Overlook Road which looks like any other street in OSM, is not in CS at all

It appears the street records do not formally exist in City Strides then - but they do in OSM.

Oh, there’s the problem … the border has been edited in OSM in a hugely breaking way … we’re not going to get anything useful out of that broken border Relation: ‪Westport‬ (‪4139426‬) | OpenStreetMap

Thanks for tracking that down! What’ the best way to correct this? Is it something you can handle or do we just need to roll back that person’s edits?

I know very little about OpenStreetMap editing, so I’m unsure what the best way to resolve this issue is. Hopefully someone reading along knows.

I’ve done minor edits, but one thing I recall seeing (once logged in I think) is a method to flag something, so other (more proficient, and perhaps local) mappers can investigate.

I’ve adjusted the title of this post to more clearly call out the request to anyone fluent in OSM that happens to be browsing around. I’ve also edited your original post to include the details.

@JamesChevalier - it looks like someone made some edits earlier today that includes “Cleaning up maritime boarders” - I think that might have fixed the issue. Can you check OSM and run an update in City Strides for Westport? Thanks!

Unfortunately the issues persists. I guess I have to suspend my support and find a new website as it seems City Strides is unable to support the run every street in my town concept anymore. Sad to go!

My data source can sometimes lag behind OSM updates, so I’m sure it’ll be sorted out soon. I’ll push the city through an update once a day until we see it corrected - assuming you’re willing to work with me on this.

I’ll note that anyone using OSM as their data source is going to have this trouble at one point in time or another. If they don’t have a team handling QA before accepting changes into their own system, it’s going to happen.

Looks ok now after the last update. At least I see Overlook Rd

Yes it appears to be updated. Thank you. It’s strange my overall % of roads completed is the same as before but I see the raw number of streets is up significantly and there are nodes associated to the streets which were missing them before.

It may have not been updated yet (?) because I see you’re at 88.04% and that seems to work out correctly: (677/769)*100
I suppose it’s that or an even ratio of new data was added which you’ve completed/not which kept your percentage the same.

Congrats, either way, you’re making really good progress!

2 Likes