Not recognizing that I've completed a street

Hi - complete newbie here. I’ve been using City Strides for a week or two and it looks great but I hit an issue today where I ran a route that should have taken in quite a few new streets. It’s been uploaded fine and I can see it on my Lifemap, but none of the streets show as either Completed or Progressed. I can see on a few of them, the GPS track is a bit wayward but on others it looks like I’ve run right down the middle of the road and it still doesn’t register.

Am I missing something here? Should I be completing them manually as I know I’ve run them?


Welcome to CS!

The processing of the completed streets sometimes takes a little while. I see you posted this yesterday, has the run changed what has completed yet?

If it is 24hrs later and things still haven’t processed, something might be going on that @JamesChevalier will need to look into.

Share your CityStrides profile page here if it needs further investitgation.

Hi, thanks. Looks like it did complete overnight and today’s streets updated pretty much immediately. I’ll leave it longer in future. It’s just that it had been so quick to update before so I thought there might have been something up.