No street progress on today's 6-mile walk

I walked 6 miles today in Hollywood. CityStrides has already added the activity (and added the map to my LifeMap), but it’s still showing zero streets progressed when there should be at least a dozen. First, what could have caused this glitch? Second, if it happens again, is there a way that I can trigger CityStrides to redo and recalculate? Obviously, syncing a second time didn’t work, so what else could be done?

The same thing happened to me on my walk today in Seattle. I completed 1 street and progressed on many, but it shows 0 of each. I tried syncing several time throughout the day but nothing worked. So I have the same question.

1 Like

If you look at the status page you see that the processing queues seem to have problems. I guess it’s nighttime for @JamesChevalier right now, so just have patience, he’ll sort this out during the day

And now it seems to be OK again, my run is processed, and the queue looks OK

1 Like

Yeah, sorry, my hosting provider had an issue that blocked a lot of processing jobs. It’s all back to normal now, so everything should have caught up.

Thanks you for that tech update. That was indeed the problem. For other reasons, though, I am still wondering about my other question… other than hitting Sync Now (which doesn’t seem to be the solution), is there any way that I can manually force CityStrides to recalculate past walks & runs?

Here’s an example. This 5.8-mile run in Los Angeles showed 2 new streets at the time I did it (the two alleys across the bottom of the map, parallel to Vanowen). Since then, OSM has added labels for six more alleys (up the west side parallel to Corbin, and across the north side parallel to Sherman). But even though CS now shows the new labels on the map, it hasn’t recalculated this past run to show my total as 8 new streets.

What can we do in these cases?


I checked one of the Alleys and it did not have a name till 7 days ago, a street needs a name to be counted in CS. When you go to a city’s CS page (e.g., Los Angeles), you will see the last update date saying 10 August. Cities update around every 4-6 weeks in CS. The alleys will show up after the next LA sync and get marked as (in)complete, depending on whether you passed enough of it (unsure whether it will update the activity’s count too, I would think so).

Incidentally, are these alley numbers marked as such on the terrain or is that just some reference the city keeps? It feels a bit weird/wrong to see these numbered names. In the case of some internal reference I feel like there might be a more appropriate tag than the name tag (i.e., a tag specific to that reference), at least that’s how I’ve seen it recommended around my parts.

Thanks, Ward. It’s true these labels were added recently to OSM, but, since they’re on the CS map, they’ve already been imported by CityStrides. Maybe it’s because the neighborhood got updated (Reseda, I think), but not yet the city of Los Angeles? In fact, that’s very likely.

But I do feel as if there are similar glitches like this… on streets that got updated longer ago and and when it was more definitive that CS hadn’t counted the new streets. So I’m still curious about the answer to the manual updating question.

As for the alleys, those are the official Los Angeles name designations. On OSM, they’re marked as name:signed=no since, yes, there are no road signs with these names.


No, what you see on the map in CS is not CS! The map used comes from Mapbox, and does not reflect the CS street import status. As Ward says, you have to wait until CS shows a new update date, looks like late September

1 Like

Ahh, that’s a good differentiation to understand. Thank you.