Marking parts of street private - cannot find some of the nodes on OSM

In one of the cities that I am running, there are a lot of private parts of streets locked behind a gate. I search in here on how to fix it and found it - so have just marked those parts that I could find into allowed access = private.

But I have run into this problem, that some of the nodes I cannot find. Is there a way to search specifically for a node? I see that the street is in many parts, and I have found some, but not all. This is the street on CS: Fabriksparken in Albertslund Kommune, Region Hovedstaden - CityStrides

Any help appreciated :slight_smile:

And what part of that streeti s private? can you send a picture with the nodes that should be private in a circle or something?

I modified OSM for that one, but there is a lot of other private streets around there! so much to do. This should be done by a local OSM’per.

The blue lines are public and runnable. the small streets inbetween are private entries to industrial places.

Next time your city it’s updated in CS, it should reflect the reality better, and if you run the blue lines, you have the street completed.

1 Like

Thanks a lot for the help! I think this will do the trick. Here’s what I have run and where the red (private) nodes are. I have managed to sneak into some of the private nodes because gates were open :sweat_smile:

1 Like

No prob. i gues you can sneak in to private area’s, but on your own risk. Better make OSM mach the reality and have patience that the changes will come to CS. (if you kow you have run the complete public part of a road, you can manually complete it. After an update it will be synced and you can uncomplete the manual completion)

1 Like

Would you please describe in more detail how you did this? There are several streets in my city that I am not able to walk in their entirety because part of the street is behind a locked gate. I don’t want to just delete the part of the street behind the gate. That part of the street is still there, it is just not accessible to foot traffic.

You can find a description of the basics here :slightly_smiling_face:

1 Like

The quick idea is to cut the street at the gate into two separate streets. Mark the part behind the gate private. And mark the cut itself as a gate.

There are lots of tutorials on the details of doing this all over the place.

My problem was that I could not find the parts of the street on OSM that I have on citystrides, and are currently as red nodes to to being private. The street is in many parts and I checked them all, but some parts I could not find at all? So could not mark them private.

I have no idea how it was fixed, but I do hope that when update comes through, that the street only consists of what is shown in th above map :blush:

One trick I have used, to identify where a private road begins, is to import my GPX file to OSM. Then I get a very good idea where things are. I run with a Garmin, and the Gamin Connect site lets users export their GPX data, on a per activity basis.


Hi all - I have a related question, sorry if this should be a different topic. My issue is that there are a few streets near me that are already marked as Private in OSM, and show up grayed out in CityStrides, but still have nodes on them despite being private (so they show up as incomplete in my NodeHunter). Is there some other way to fix this if the street is already marked as Private? See screenshot below (it is Orleans East in San Diego, if that helps).

The graphic of the map is not generated from the data that OSM has; it’s from a separate source. That source is updated often. It is quite possible that the roads were marked private after the city was last updated by OSM, but before the map generator picked up the information.

This confused me, too, the first time I noticed a node in the middle of a field.


Do you have an idea of how long it takes for the nodes to disappear? I had this same situation where paths and courtyards of Hampton Court Palace had been added to OSM - but you have to pay to gain access. I’ve now amended them to private in OSM. The update of CityStrides at the end of March has now removed the roads from the incomplete list but the nodes remain. I guess it’s a month or so, but wondered if anyone knew.

If the city that has the paths and courtyards of Hampton Court Palace is nested, or contains nested cities, then you might be seeing a case where the streets still exist in the other cities.
Let me know if that’s the case - it’ll help direct me in my debugging (and help determine if it requires any debugging).

Hello all - happy to bump this to a new thread if that helps, but I have a slightly similar issue. I have a street that has somehow begun to show as open (i.e. not private) even though it is private and restricted via FOB access. The city is Alexandria, VA (171336) and I’ve attached an image of the street below. I did visit OpenStreeMap to make the modification, but it still shows as nodes to be completed (or possible for completion) in CityStrides. I even double checked by running around the entire perimeter, but it appears that anyone who picks up those nodes either lives in the complex OR waited until a car entered and piggybacked in through the gate (and I’m assuming, successfully escaped haha). The street is Luna Park Drive.

Hi @ace720e21bee4f31b3f8 , changes made in OSM take roughly one month before they are updated in the CS database. The last OSM update date is displayed on each city’s page, so you can get a rough idea when you’ll see the changes here.

1 Like

This is in the London Borough of Richmond Upon Thames, which is indeed nested in Greater London. And having now checked, “The Lime Walk” (the curved path here) is still showing in the Greater London list of roads but is not in the Richmond list.

I ran that same stretch of road a couple of months ago by following a car in… and escaped shortly after :slight_smile:

I’ve had to do the same in a handful of other areas in the City of Alexandria.

1 Like