MapMyRun Disconnected.. Not Reflected in CityStrides

I disconnected my MMR and RunKeeper connections, as I wanted to use only Strava - due to some issues with old data which I’ve fixed only in Strava.

RunKeeper shows as not connected, but MMR is still listed as connected. On my Profile, and my Settings screen.
Note: I disconnected it several months ago - and it appears as though I haven’t had any activities come in from MMR in that time, but it still seems to think I’m connected.

Just wanted to point this one out in case it somehow glitched. I was going to reconnect and disconnect again, to see if that worked, but because it doesn’t seem to be showing MMR activities, I never bothered.

Note: I don’t record anything in MMR these days either, but everything I record from my watch is synced to both Strava and MMR - so depending on whether/how your system works out duplicates, they may actuallly be syncing and just not showing as the Strava connection takes precedence? I’m not too sure - could manually create an activity in MMR and see what happens, but again - because it’s not actually causing me any real grief, I haven’t bothered.

Just a small update - the link to MapMyRun links to:
http://www.mapmyfitness.com/profile//
It should now link to
https://www.mapmyfitness.com/account/my_profile

Due to an update on the MMR end.

And, in fact, you’re probably better still linking directly to the Authorised Apps screen:
https://www.mapmyfitness.com/oauth/manage/
Ditto for Strava:
https://www.strava.com/settings/apps
And RunKeeper:
https://runkeeper.com/settings/apps

Thanks! :smile:

I merged these two posts because they’re the same root cause.

It does look like I’m not handling MMR de-authorizations correctly. It also looks like MMR’s error responses have changed since I originally wrote that code. :man_facepalming:

I’ve cleaned up your account, and added a to-do item to correctly handle MMR access issues. Thanks!