MapMyFitness Sync Issue

Hey, MapMyRun user here. Sorry if I should be posting this elsewhere but it seems as though I’m having an ongoing issue rather than a one or two time sync problem.

It turns out, I’m missing quite a bit of activity. They are all on my MapMyRun account but not on my profile on CityStrides or on my LifeMap. I have tried Syncing Now, logging out, clearing my cache, etc. So far, nothing has worked.

The following dates seem to be missing:
May 28, 30, 31; June 1, 2, 3, 4, 7, 8, 10, 12.

Thanks for your help! I love this site!

To do anything, the Powers that Be will need to have your CS profile information. It is also useful to make your profile public so he can actually look at it.

Gravy would include including your MapMyRun profile link, with it being public, too. (I’m not sure if it’s needed, so this is more of a just in case.)

No no - I don’t need any privacy changes!
Privacy is VERY important to me - I want everyone to be able to keep things as private as they’d like.

I’ve got this (and a few others :sweat_smile: ) thread bookmarked to review soon … it does seem like there some MapMyRun issue going on, but I haven’t seen anything consistent about the reports so far.

Thanks for your patience!

I think I see these activities coming in now. There are multiple activities per day, and I’m seeing dates that you mention in your post.
Sounds like there was some issue with syncing MMR recently? :man_shrugging:

Hi, I also am having the same problems. I’m missing at least one from May, and none of my June workouts have shown up.

Please try logging out of CityStrides, then logging back in. After doing that, try a sync now (or reply here with your profile link if you don’t have access to that).

Appreciate your help!

Any luck?

Apologies for being needy, wife is getting more streets than me.

1 Like

Just looked at the data for your MapMyRun connection, and it’s missing the token. This can be resolved by logging out of CityStrides & logging back in. After you do that, syncing should work - let me know when you’ve done that & I can run a sync now for you.


Appreciate the help. Fingers crossed it works!