Lifemap synced on one device but not on another

Hi there,
My Lifemap is synced correctly on my phone, but my latest activity is still not showing up when I look at City Strides on my desktop. Any reason for this or suggestions on how to resolve the issue?

:thinking: I’m not sure how this is even possible. There’s one source of data for the display of the LifeMap, it’s not unique per browser.
Maybe there’s some browser caching involved? You could try refreshing the page while holding the shift key down…

Yes, I thought it was an extremely odd issue. It seems to have fixed itself now… though I am awaiting the Lifemap sync from a new activity, so I will let you know if there are any further occurrences. And, yes, I had tried everything I could think of: logging off and back in, refreshing, going to a different part of the site and then back, closing the browser completely and then reopening, simply waiting. Just a gremlin, I suppose.

Also, I’m not sure how long it is supposed to take the Lifemap to sync, but it’s been a couple hours now and it still hasn’t.

Is the activity in CityStrides?

If you share a link to your profile and activity (it’s ok if it’s private) I can look into it.

Yup, it’s listed: J. Pownall's activity on May 11, 2022 - CityStrides

I know I’ve only been on here for a couple of days, so I’m really just trying to get a sense of what’s typical for the site, but if it does seem anomalous you may be interested to know most of my other activities seem to have taken quite a while to copy over to the Lifemap as well (over ten minutes to hours).

Thanks for investigating! I am grateful you make yourself so available on here.


I think ~10 minutes isn’t too uncommon. The Status page includes a chart for “Non-Supporter LifeMap Delay”, which is decently accurate & can reach 10mins at times. Anything over ~20-30mins, and something funky is going on.

Your public LifeMap displays the activity for me:

I downloaded your private LifeMap from my file hosting service & confirmed that it’s present in there as well. I do use cache services to decrease my bandwidth bill, but if it was caught up in that I wouldn’t be able to see it.
It’s possible that the timing of all this worked out in a way that displayed the cached data for you and the new data for me.

I would expect that right now, your LifeMap is up to date and displaying the activity for you. If it isn’t, then this sounds like some kind of browser issue. :thinking: Or something else outside of my control is caching data just for you.

Thanks, James,
It’s showing up on my end now too. I have no idea why I’m getting these delays, but everything is eventually showing up. I’ll just practice patience and be grateful I found a site that offers such a useful motivational tool for those of us looking to find ways to stay more active.
Thanks again,

One test we could run, if you’re quite patient because the timing might be difficult to match perfectly:

  • Save the activity in Runkeeper
  • Do not visit your LifeMap page
  • Let me know you’ve saved an activity
  • I manually run a sync to get it into CityStrides faster (if I’m available at the time you save your activity, anyway)
  • I confirm when the LifeMap job completes
  • I let you know when all this is done
  • You visit your LifeMap to see if it’s present

This would test my theory that you’re visiting your LifeMap before all the processing can be done, which is setting the cache on that data, and it isn’t being updated for some time afterwards.

I use Map My Walk, and i just uploaded a new activity on there. I haven’t logged onto City Strides for this one yet… will that work?

:man_facepalming: sorry I don’t know how I got Runkeeper in the mix. It does make it easier, though.

  • Save the activity in MapMyWalk
  • MapMyWalk will automatically send the data to CityStrides
  • Let me know when the activity is present in your profile page
  • I’ll confirm the LifeMap job completes & let you know
  • You visit your LifeMap to see if it’s present

I manually checked your connected account and the newest activity they’re returning is from May 12. :thinking:

I just signed into City Strides and today’s is on my profile page. I have not checked my Life Map.

I’m going to be heading out for a walk in a few, so I will take a peak at my Lifemap before I leave. When I return I’ll let you know once the new activity is loaded on MapMyWalk and then when it turns up on my City Strides profile (I hope I understood that correctly). If the timing works out for you to confirm the LifeMap completion great, but I certainly don’t want to monopolize your efforts here. :slight_smile:

Yeah, sorry the timing didn’t work out for the previous walk.
Another thing to try, if our timing doesn’t match up again, is to check the Status page when your activity arrives & wait however long the “Non-Supporter LifeMap Delay” is before opening your LifeMap.

No worries, and will do! I just uploaded the newest activity onto MapMyWalk. It appeared within a minute or two on my City Strides profile page. Also, the previous one was on the LifeMap when I looked at it before heading out earlier.

OK, that LifeMap queue is down below 5mins & your public LifeMap includes the new activity. Is it present on your LifeMap now?

Nope. Nothing on my LifeMap yet.

Just tried refreshing and signing out and back in, but it is still missing. I guess this means the issue is on my end. I do appreciate all you tried to do here though. Thank you!

And just for fun I checked it on my phone and it IS present on there. It must be an issue specific to my desktop.

:thinking: this is bizarre … the fact that it worked on your phone rules out the idea I was trying to test - that the data was cached :cloud: in the cloud :cloud:

If it’s a browser cache issue, then I would expect it could be proven by opening a private browser window & logging into CityStrides (important step) & then viewing your LifeMap … it wouldn’t have access to the cached data in the non-private window, so it should show you your full and up to date LifeMap

If that still shows a non-updated LifeMap, then it might point to some local network/device cache … but in that case I’d probably expect your phone while on the same wifi as your computer would show the same outdated LifeMap

…computers :confounded: