Impossible to navigate in LifeMap (with iPad/iPhone)


#1

Hi,
First, thanks for your great job on Citystrides !

I hope no other thread has been open for similar issue, but if so, I haven’t find it through any search.
Since 2 or 3 weeks (approx.) I can’t navigate into LifeMap with my iOS devices (iPad, iPhones) any more. I mean, zooming buttons are still working, but I cannot move the map Up, Down, Left or Right with my fingers… where it worked perfectly before !
And I’ve no issue with laptop nor desk computer (Mac or Windows). Have I missed something ?

Thanks your helping.

Best regards,
JB


#2

Hi JB
Yes, i have the same thing and did post it as well. I did find out that when I activate live position and I move the map touching live location it does work, maybe this will help charles troubleshooting.
What I also notice is that the top bar is moving instead of the map if I try to move the map.
Richard.


#3

Hey @jbbommier … I can’t reproduce this. :frowning_face:

When I navigate to my (or your) LifeMap page, I can navigate around the map as expected - one finger drag to pan around, two finger pinch to zoom in/out, and two finger twist to reorient the map. I do notice that if I three-finger drag around, that weirdly moves the full webpage around - it doesn’t interact with the map.

This is definitely an issue that was reported in previous Mapbox (the map service I use) versions, but I haven’t seen it in the wild in a while.

Which iPhone device do you have, and which iOS version are you using?


#4

Hi @JamesChevalier !

Actually, what you’re describing on your side for 3-fingers drag is the behaviour I get with any 1, 2 or 3-fingers operation : it moves or zooms the full webpage but not the map. Only the buttons can operate (zoom +/- and toggling to satellite view).

This happens for both iPhones (iPhone SE with iOS 11.4.1 or iPhone 8 with 11.4.1) and iPad (with iOS 10.2). This also happens when I switch to “desktop version” of the website.

Please tell me if I can bring any other information.
And, by the way : Merry Christmas ! :slight_smile:

JB


#5

Similar here. Might a workaround be to allow the mobile site to open the desktop version like you have in the fora part of your site?

I am thinking about shooting a video with my iPhone of this behavior from my iPad. Would that help?

Merry Christmas.


#6

I’m not even aware of a “switch to desktop version” feature! :laughing: :joy:

I’ve definitely seen this issue in the past, but haven’t been able to reproduce it with later versions of Mapbox/iOS. I think device and OS specs as well as URLs for pages that have this problem would help the most.

@jbbommier / @RichardRichard - Does this behavior exist for all maps throughout the CityStrides site?


#7

@JamesChevalier you’re a better troubleshooter than me : it appears that other maps do work well ! For instance Maps for Cities or Activities.

So it seems the trouble only appears for Livemap : mine, but also other members (I’ve tried).

Another thing : it works well (I mean Lifemaps) on my wife’s iPhone running with iOS 12. So I’m currently upgrading one of my two iPhones, to check if this is related.

JB


#8

Hi James
For me it is only in live map, where you can start node hunter. Also on the live maps of others. But not on a city map or when you look at a completed street.
In safari I found a toggle where I can switch to the desktop site but that didn’t solve the issue.

Thanks for looking in to this


#9

Ok so I made a really sloppy quick video with my phone from my iPad and uploaded it here https://youtu.be/6x19mWsRbdM
Maybe this helps?


#10

Hello Guys,
I’ve updated my first iPhone (8) to iOS12 and… now Lifemap is working as expected ! :sweat_smile:
I’m currently updating my other device (so loooong), I’ll let you know if it solves for them also.

@JamesChevalier: by the way, NodeHunter rocks !!


#11

Thanks @RichardRichard !
My current guess is that either this is an issue that only exists in older iOS versions (upgrading helped @jbbommier ) or there’s a javascript error occurring & that’s breaking expected Mapbox behavior. The process to debug javascript errors on iOS devices is rough (debugging description) … can you share a link to your LifeMap @RichardRichard ?


#12

Hi James
Updating IOS On my phone solved the issue, thanks. I do feel a bit stupid now, thought I had automatic updates on.
Thanks for the help again.
Wishing you and your loved ones a great 2019.
Richard


#13

Hello !
Updating iOS made it both on iPhones & iPad. This is strange, as iOS 11.4 or even 10.x were not so old, but anyway : now it works! Thanks for helping. Now it’s time to hunt the remaining nodes. :smile:
See you all in 2019,
JB